summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYuval Adam2015-06-30 15:50:06 +0300
committerYuval Adam2015-06-30 15:50:06 +0300
commitae083d20c951b8d2ad32440f3fec95773b31b247 (patch)
treec246227d7886835df0dbb72d28704525c498331e /PKGBUILD
downloadaur-ae083d20c951b8d2ad32440f3fec95773b31b247.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee77076d4bed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Yuval Adam <yuval at y3xz dot com> PGP-Key: 271386AA2EB7672F
+
+pkgname=frequensea-git
+pkgver=3707384
+pkgrel=1
+pkgdesc="Visualizing the frequency spectrum"
+arch=('any')
+url="https://github.com/fdb/frequensea/"
+license=(MIT)
+depends=('rtl-sdr' 'glew' 'glfw' 'lua' 'fftw' 'libpng' 'openal')
+provides=('frequensea')
+source=('git+https://github.com/fdb/frequensea/')
+sha1sums=('SKIP')
+_gitname=frequensea
+
+pkgver() {
+ cd $_gitname
+ echo $(git describe --always | sed 's/-/./g')
+}
+
+build() {
+ cd $_gitname
+ mkdir build
+ cd build
+ cmake ..
+ make
+}
+
+package() {
+ install -Dm755 ${srcdir}/${_gitname}/build/frequensea ${pkgdir}/usr/bin/frequensea
+}
+
+# vim:set ts=2 sw=2 et: