summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRaphaël Doursenaud2015-07-05 17:58:37 +0200
committerRaphaël Doursenaud2015-07-05 17:58:37 +0200
commitf98e281e84ec3059bb0eb50ce2d3774f4c56038b (patch)
tree921e03939693d9c95cbf6f556ee0c390125964fa /PKGBUILD
downloadaur-f98e281e84ec3059bb0eb50ce2d3774f4c56038b.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD62
1 files changed, 62 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b5ed6aebce9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Raphaël Doursenaud <rdoursenaud@free.fr>
+
+pkgname=frescobaldi-git
+pkgver=v2.18.1.r3.g6b4031a
+pkgrel=1
+pkgdesc="A LilyPond sheet music text editor."
+arch=('any')
+url="http://www.frescobaldi.org/"
+license=('GPL')
+depends=(
+ 'hyphen'
+ 'poppler'
+ 'python>=3.2'
+ 'python-ly'
+ 'python-poppler-qt4'
+ 'python-pyqt4>=4.8.3'
+ 'qt4>=4.7'
+ 'tango-icon-theme'
+)
+optdepends=(
+ 'lilypond: Music engraving (recommended)'
+# python-portmidi is currently a python2 package
+# 'python-portmidi: MIDI playback (default engine)'
+ 'python-pygame-hg: MIDI playback (alternate engine)'
+ 'portmidi: MIDI playback (fallback engine)'
+ 'hyphen-de: German hyphenation rules'
+ 'hyphen-en: English hyphenation rules'
+ 'hyphen-es: Spanish hyphenation rules'
+ 'hyphen-fr: French hyphenation rules'
+ 'hyphen-hu: Hungarian hyphenation rules'
+ 'hyphen-it: Italian hyphenation rules'
+ 'hyphen-nl: Dutch hyphenation rules'
+ 'hyphen-ro: Romanian hyphenation rules'
+)
+conflicts=('frescobaldi')
+provides=('frescobaldi')
+source=("$pkgname"::'git://github.com/wbsoft/frescobaldi.git')
+install=frescobaldi-git.install
+md5sums=('SKIP')
+
+_gitroot='https://github.com/wbsoft/frescobaldi.git'
+_gitname='frescobaldi'
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ # Provided by tango-icon-theme
+ rm -rf "frescobaldi_app/icons/Tango"
+ # Provided by hyphen-*
+ rm -rf "frescobaldi_app/hyphdicts"
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: