summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfbt2016-03-11 11:51:21 +0300
committerfbt2016-03-11 11:51:21 +0300
commit015cb08a70e468d3282505de7a54ab68444c6f53 (patch)
treebb15415276e35454dbeda1c1d6c68b4fbf1767fb /PKGBUILD
parent13c8f0f9d7fc362cc72b5faa7718dff11adcfff6 (diff)
downloadaur-015cb08a70e468d3282505de7a54ab68444c6f53.tar.gz
Fixes; new contributor.
Signed-off-by: fbt <fbt@fleshless.org>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 17 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 63ac4835a11a..291eb7b4310c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,29 @@
# Maintainer: Jack L. Frost <fbt@fleshless.org>
-# vim: expandtab sts=2
# Contributor: Corelli <corelli AT sent DOT com>
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: intelfx <intelfx100 [at] gmail [dot] com>
# Contributor: Behem0th <grantipak@gmail.com>
+# Contributor: zman0900 <zman0900@gmail.com>
pkgname=freshplayerplugin-git
-pkgver=v0.3.3.r0.g6018406
+pkgver=v0.3.4.r21.g7ba5f2d
pkgrel=1
pkgdesc='PPAPI-host NPAPI-plugin adapter.'
arch=( 'i686' 'x86_64' )
url='https://github.com/i-rinat/freshplayerplugin'
license=( 'MIT' )
-depends=( 'pango' 'alsa-lib' 'freetype2' 'libevent' 'gtk2' 'libgl' 'v4l-utils' 'ffmpeg' )
+depends=( 'pango' 'alsa-lib' 'freetype2' 'libevent' 'gtk3' 'libgl' 'v4l-utils' 'ffmpeg' )
makedepends=( 'cmake' 'ragel' 'git' )
conflicts=( 'freshplayerplugin' )
source=( "${pkgname}::git+${url}" "${pkgname}.install" )
install="${pkgname}.install"
optdepends=(
- 'chromium-pepper-flash: for the necessary Pepper plugin'
- 'chromium-pepper-flash-standalone: for the necessary Pepper plugin'
- 'google-chrome: for the necessary Pepper plugin'
- 'google-chrome-beta: for the necessary Pepper plugin'
- 'google-chrome-dev: for the necessary Pepper plugin'
+ 'chromium-pepper-flash: for the necessary Pepper plugin'
+ 'chromium-pepper-flash-standalone: for the necessary Pepper plugin'
+ 'google-chrome: for the necessary Pepper plugin'
+ 'google-chrome-beta: for the necessary Pepper plugin'
+ 'google-chrome-dev: for the necessary Pepper plugin'
)
pkgver() {
@@ -38,17 +38,18 @@ pkgver() {
}
build() {
- cd "$pkgname"
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr
- make
+ cd "$pkgname"
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DWITH_GTK=3
+ make
}
package() {
- cd "$pkgname"
- install -d "${pkgdir}/usr/lib/mozilla/plugins"
- install -m644 libfreshwrapper-*.so "${pkgdir}/usr/lib/mozilla/plugins"
- install -Dm644 data/freshwrapper.conf.example "${pkgdir}/usr/share/${pkgname}/freshwrapper.conf.example"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "$pkgname"
+
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm644 data/freshwrapper.conf.example "${pkgdir}/usr/share/${pkgname}/freshwrapper.conf.example"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
sha1sums=('SKIP'