summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhillip Smith2015-06-02 10:47:24 +1000
committerPhillip Smith2015-06-02 10:47:24 +1000
commit7074f63518e4d7f3810f13a62bd65895b6e5d1bc (patch)
tree0674d2ae496c82f8d39ff9b3c8b92c69637f7c38 /PKGBUILD
downloadaur-7074f63518e4d7f3810f13a62bd65895b6e5d1bc.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1413a7c733a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Phillip Smith <fukawi2@NO-SPAM.gmail.com>
+# http://github.com/fukawi2/aur-packages
+
+### I AM ONLY THE PACKAGER, NOT THE DEVELOPER
+### Please ask support questions about this software in one of:
+### 1) The AUR comments; OR
+### 2) Upstream forums/maillist etc; OR
+### 3) The ArchLinux forums
+### I do not always know enough about the software itself, or don't have the
+### time to promptly respond to direct emails.
+### If you have found a problem with the package/PKGBUILD (as opposed to
+### the software) then please do email me or post an AUR comment.
+
+pkgname=freshwall
+pkgver=1.1.2
+pkgrel=3
+pkgdesc="Wallpaper rotator for Gnome using files found in ~/.gnome2/backgrounds.xml"
+arch=(any)
+url="http://pypi.python.org/pypi/freshwall/"
+license=('Apache')
+source=("http://pypi.python.org/packages/source/f/$pkgname/$pkgname-$pkgver.tar.gz")
+md5sums=('bf8911f94ab37766f64bfd5c1f39cb30')
+
+build() {
+ msg "Nothing to compile for $pkgname"
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+
+ msg "Creating dirs..."
+ install -dm755 $pkgdir/usr/bin/
+ install -dm755 $pkgdir/usr/lib/python2.6/site-packages/$pkgname/
+
+ msg "Copying files..."
+ cp bin/* $pkgdir/usr/bin/
+ cp lib/$pkgname/* $pkgdir/usr/lib/python2.6/site-packages/$pkgname/
+
+ msg "Forcing usage of python2"
+ sed -e 's|^#!/usr/bin/env python$|#!/usr/bin/python2|g' \
+ -i $pkgdir/usr/bin/*
+
+ msg "Setting permissions..."
+ chmod 755 $pkgdir/usr/bin/*
+}
+
+# vim:set ts=2 sw=2 et: