summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorM0Rf302020-02-01 10:40:52 +0100
committerM0Rf302020-02-01 10:40:52 +0100
commit2f0888b4ff735f8b841f457b9a2ab30d376fa339 (patch)
treebf5888ee4642b30c27544c389f567710ffe37d52 /PKGBUILD
parentd18e0b610790c3cc1878260b1cb9ce19df63e39a (diff)
downloadaur-2f0888b4ff735f8b841f457b9a2ab30d376fa339.tar.gz
friture: fix crash & added wheel as makedep
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e7ab01db0d54..bfb3904a2bc7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,20 @@
pkgname=friture
pkgver=0.41
-pkgrel=1
+pkgrel=2
pkgdesc="An application to visualize and analyze live audio data in real-time."
arch=(i686 x86_64)
url="http://tlecomte.github.com/friture/"
license=('GPL3')
depends=('python-appdirs' 'python-docutils' 'python-multipledispatch' 'python-numpy' 'python-opengl' 'python-pa-ringbuffer' 'python-pyqt5' 'python-pyrr' 'python-rtmixer' 'python-sounddevice')
optdepends=('jack: for JACK I/O support')
-makedepends=('cython')
-source=("https://github.com/tlecomte/$pkgname/archive/v$pkgver.tar.gz")
+makedepends=('cython' 'python-wheel')
+source=("https://github.com/tlecomte/$pkgname/archive/v$pkgver.tar.gz"
+ numpy.patch)
build() {
cd "$srcdir/$pkgname-$pkgver"
+ patch -Np1 -i ../numpy.patch
python setup.py build
}
@@ -27,4 +29,5 @@ package() {
sed -i "s|usr|/usr|g" "$pkgdir"/usr/share/applications/$pkgname.desktop
}
-sha256sums=('f778798392ff29284c2cdbc3563ec83552b8a8a464a5ad35e5678448cc335a7c')
+sha256sums=('f778798392ff29284c2cdbc3563ec83552b8a8a464a5ad35e5678448cc335a7c'
+ '311df0ab345e57b0baee49a94165cbb37fc9ade4d74c7b81b4a3b542ee4bfdc1')