summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorM0Rf302023-06-03 23:55:02 +0200
committerM0Rf302023-06-03 23:55:02 +0200
commit907bd17b67c4505c8e40cf7384dc909ca52bb552 (patch)
tree62db52c495b6065d2466f25903c29494ae72ff84 /PKGBUILD
parentf325345cd0dbfd4f7fd6db43e14bcec6040f7fb5 (diff)
downloadaur-907bd17b67c4505c8e40cf7384dc909ca52bb552.tar.gz
friture: fixes for latest python 3.11
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 16 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2a03eeb15b75..cc7bbc3eceea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,26 @@
pkgname=friture
pkgver=0.49
-pkgrel=1
+pkgrel=2
pkgdesc="An application to visualize and analyze live audio data in real-time."
arch=(i686 x86_64)
url="https://friture.org/"
license=('GPL3')
-depends=('python-appdirs' 'python-docutils' 'python-multipledispatch' 'python-numpy' 'python-pa-ringbuffer' 'python-pyqt5' 'python-pyrr' 'python-rtmixer' 'python-sounddevice')
+depends=('python-appdirs' 'python-docutils' 'python-multipledispatch' 'python-numpy'
+ 'python-pa-ringbuffer' 'python-pyqt5' 'python-pyrr' 'python-rtmixer'
+ 'python-sounddevice')
optdepends=('jack: for JACK I/O support')
makedepends=('cython' 'python-pip' 'python-setuptools' 'python-wheel')
-_commit=ea7210dae883edf17de8fec82f9428b18ee138b6
-source=("https://github.com/tlecomte/friture/archive/refs/tags/v${pkgver}.tar.gz")
+source=(
+ "https://github.com/tlecomte/friture/archive/refs/tags/v${pkgver}.tar.gz"
+ python3.11.patch
+)
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ patch -Np1 -i ../python3.11.patch
+}
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -34,4 +44,5 @@ package() {
"${pkgdir}/usr/share/applications/${pkgname}.desktop"
}
-sha256sums=('9643c56c4901ae892e16a35c418099bb28784bc4baeebfcf1cd8ea0f9b5de743')
+sha256sums=('9643c56c4901ae892e16a35c418099bb28784bc4baeebfcf1cd8ea0f9b5de743'
+ '253b32b6e4b4855fe06f9fc8b4a6ed03eb0241a434ddc6ad9baa2bf2b3939250')