summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabio2015-06-30 14:13:43 +0200
committerFabio2015-06-30 14:13:43 +0200
commitc658732ab43911bf2d2397269bd65ec35587190f (patch)
treee310fbe1ac4c35bc99bfa3ef1c7fe41916aa3e82 /PKGBUILD
downloadaur-c658732ab43911bf2d2397269bd65ec35587190f.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..495e3899ba47
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Fabio Rämi <fabio[at]dynamix-tontechnik[dot]ch>
+
+pkgname=friture
+pkgver=0.14
+pkgrel=1
+pkgdesc="An application to visualize and analyze live audio data in real-time."
+arch=(i686 x86_64)
+url="http://tlecomte.github.com/friture/"
+license=('GPL3')
+depends=('pyqwt' 'python2-scipy' 'python2-psutil' 'python2-pyaudio')
+optdepends=('jack: for JACK I/O support')
+makedepends=('cython2')
+source=("http://pypi.python.org/packages/source/f/$pkgname/$pkgname-$pkgver.tar.gz")
+md5sums=('866407aefd359ae16015f4ce6a2cd212')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir/"
+
+ # python2, CRLF fix
+ sed -i 's/\r//;s/env python/&2/' `find "$pkgdir" -name "*.py"` \
+ "$pkgdir/usr/bin/$pkgname"
+}
+
+# vim:set ts=2 sw=2 et: