summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMike Swanson2014-06-14 10:19:58 -0700
committerMike Swanson2014-06-14 10:19:58 -0700
commit7369455e796434b8637c82eef48a039dee2e88aa (patch)
tree6bf34232c13173a7f47f6242a9673b29e413ad71 /PKGBUILD
parentd819a209ed5375231e7ab9b83305ff1327988eb5 (diff)
downloadaur-7369455e796434b8637c82eef48a039dee2e88aa.tar.gz
Use p7zip and graphicsmagick to extract an icon out of Freespace 2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 13 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e284aa642832..1008fad2abc6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,12 +22,12 @@
pkgname=fs2_open-data
pkgver=1.20
-pkgrel=4
+pkgrel=5
pkgdesc="Freespace 2 retail data for fs2_open"
arch=('any')
url="http://www.gog.com/en/gamecard/freespace_2"
license=('custom:freespace2')
-makedepends=('innoextract' 'recode')
+makedepends=('graphicsmagick' 'innoextract' 'p7zip' 'recode')
# This package is about 2 GiB uncompressed and takes
# a while to recompress for not too much space savings;
@@ -59,6 +59,15 @@ prepare() {
from the retail CD and try again."
return 1
fi
+
+ # Extract and convert the icon
+ # Untested with the CD version
+ if [[ -f readme.txt ]]; then
+ 7z e FreeSpace2.exe .rsrc/ICON/3.ico
+ else
+ 7z e app/FreeSpace2.exe .rsrc/ICON/3.ico
+ fi
+ gm convert 3.ico freespace2.png
}
package() {
@@ -70,6 +79,8 @@ package() {
fi
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D -m644 freespace2.png "$pkgdir/usr/share/icons/freespace2.png"
+ rm -f freespace2.png
# This whole thing goes in /opt/fs2_open as a lot of upstream stuff
# expects binaries and data to be together like in Windows