summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorslokhorst2022-01-21 21:19:41 +0100
committerslokhorst2022-01-21 21:19:41 +0100
commitbec39f74dc90d27a5c79983df34e7d40dfe0acfa (patch)
treeb3e74f52cda7b4d2e24f6bc94e7ddec408517c05 /PKGBUILD
downloadaur-bec39f74dc90d27a5c79983df34e7d40dfe0acfa.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..41bfe391b974
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Sebastiaan Lokhorst <sebastiaanlokhorst@gmail.com>
+
+pkgname=fs2es-indexer
+pkgver=0.3.0
+pkgrel=1
+arch=('any')
+pkgdesc='File system indexer for Elasticsearch'
+url='https://github.com/Ellerhold/fs2es-indexer'
+depends=('python-elasticsearch' 'python-yaml')
+makedepends=('python-setuptools' 'git')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/Ellerhold/fs2es-indexer/archive/refs/tags/$pkgver.tar.gz")
+sha512sums=('7a8921ad858c9add46405ff0850b39ca1f2d2947025d09e382d5575d6bc2f9daea033cfc7357b901ed222c780d368db5965390036fad7127367ce72333a55b25')
+
+build() {
+ cd $pkgname-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd $pkgname-$pkgver
+ python setup.py install --root "$pkgdir" --optimize=1
+}