summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEric Biggers2021-05-05 21:42:50 -0700
committerEric Biggers2021-05-05 22:24:26 -0700
commit4aa12bc7595a40586dc539adf695c23e4783ef8d (patch)
treeb7c52fb13e4911fbbbf08e2656ec6d1ab0b4eaef /PKGBUILD
parent85153aad983728f20d6f01c060445eb83b57d061 (diff)
downloadaur-4aa12bc7595a40586dc539adf695c23e4783ef8d.tar.gz
Update to follow latest Arch Linux Go packaging guidelines
Also make use of the new way to avoid installing the Ubuntu-specific PAM config file.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e8f407b2330b..33d0fbcd2ac4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Eric Biggers <ebiggers3 at gmail dot com>
pkgname=fscrypt-git
-pkgver=0.2.7.0.g2b160ae
+pkgver=0.3.0.4.g677ae75
pkgrel=1
pkgdesc='A tool for managing Linux filesystem encryption'
arch=('x86_64')
url='https://github.com/google/fscrypt'
license=('Apache')
-makedepends=('go-pie' 'git')
+makedepends=('go' 'git')
depends=('pam')
conflicts=('fscrypt')
provides=('fscrypt')
@@ -23,15 +23,13 @@ pkgver() {
build() {
cd fscrypt
- make
+ make GO_FLAGS="-buildmode=pie -mod=readonly -modcacherw" \
+ GO_LINK_FLAGS="-s -w -linkmode=external"
}
package() {
cd fscrypt
- make DESTDIR="$pkgdir" PREFIX=/usr install
+ make DESTDIR="$pkgdir" PREFIX=/usr PAM_CONFIG_DIR="" install
install -Dm644 ../pam_config "${pkgdir}/etc/pam.d/fscrypt"
install -Dm644 -t "$pkgdir/usr/share/doc/fscrypt/" README.md
-
- # Remove Ubuntu-specific PAM file
- rm -rf "$pkgdir"/usr/share/pam-configs/
}