summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTobias Bachmann2020-09-29 20:35:07 +0200
committerTobias Bachmann2020-09-29 20:35:07 +0200
commit8f6d9824c474405b13f9bc4af8d5def96c774399 (patch)
tree8ac38b579dbc2e8b63e51f94494b8012c03d0ba6 /PKGBUILD
parent96d7b7b1ec173ece68b44bfd2d9691b94dbd8f63 (diff)
downloadaur-8f6d9824c474405b13f9bc4af8d5def96c774399.tar.gz
Version bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c5036100efec..5ab1f5e1e871 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Tobias Bachmann <tobachmann@gmx.de>
pkgname=fsleyes
pkgver=0.34.2
-pkgrel=1
+pkgrel=2
pkgdesc="FSLeyes is the FSL image viewer"
arch=('any')
url="https://fsl.fmrib.ox.ac.uk/fsl/fslwiki/FSLeyes"
license=('Apache')
groups=()
-depends=('python' 'python-setuptools' 'python-sphinx' 'python-six' 'python-numpy' 'python-matplotlib' 'python-nibabel' 'python-jinja' 'python-opengl' 'python-pyparsing' 'python-pillow' 'python-scipy' 'python-opengl-accelerate' 'python-pathlib2' 'python-wheel' 'python-twine' 'python-pytest-timeout' 'python-pytest-xdist' 'python-wxpython>=4.0.1-2' 'fslpy>=3.2.2' 'fsleyes-widgets>=0.9.0' 'fsleyes-props>=1.7.0')
+depends=('python' 'python-setuptools' 'python-sphinx' 'python-six' 'python-numpy' 'python-matplotlib' 'python-nibabel' 'python-jinja' 'python-opengl' 'python-pyparsing' 'python-pillow' 'python-scipy' 'python-opengl-accelerate' 'python-pathlib2' 'python-wheel' 'python-twine' 'python-pytest-timeout' 'python-pytest-xdist' 'python-certifi' 'python-wxpython>=4.0.1-2' 'fslpy>=3.2.2' 'fsleyes-widgets>=0.9.0' 'fsleyes-props>=1.7.0')
optdepends=('fsl: Enable loading standard images and advanced features (highly recommended)'
'python-wxnatpy: Enable loading overlay from XNAT'
'python-indexed-gzip: Fast random access of gzipped image files'
@@ -17,10 +17,8 @@ provides=()
conflicts=()
replaces=()
source=("${pkgname}-${pkgver}.tar.gz::https://git.fmrib.ox.ac.uk/fsl/fsleyes/fsleyes/repository/archive.tar.gz?ref=${pkgver}"
- "${pkgname}.png::https://git.fmrib.ox.ac.uk/uploads/-/system/group/avatar/85/icon_512x512.png"
"${pkgname}.desktop")
sha256sums=('3be3cdaa2e98d288be35381e7879fa07e690e9497bd6076089c3bd52aa6ae1b8'
- 'c7211ee624483a272f280b3aa772046ec9226d838f9c3023450888abddf9d71a'
'6e91e88eb74602f8da7cda6575245dbaaf4577022bffe15c0efedb33106139fb')
package() {
@@ -28,6 +26,6 @@ package() {
python setup.py install --root="${pkgdir}/" --optimize=1
- install -Dm644 "${srcdir}"/${pkgname}.png "${pkgdir}"/usr/share/icons/hicolor/512x512/apps/${pkgname}.png
+ install -Dm644 ./assets/icons/app_icon/fsleyes.iconset/icon_512x512.png "${pkgdir}"/usr/share/icons/hicolor/512x512/apps/${pkgname}.png
install -Dm644 "${srcdir}"/${pkgname}.desktop "${pkgdir}"/usr/share/applications/${pkgname}.desktop
}