summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTobias Bachmann2017-10-11 13:10:27 +0200
committerTobias Bachmann2017-10-11 13:10:27 +0200
commit8449bbd7be6de2d3e6c313081d4ba81e41b88afa (patch)
tree5c0dd400fccb17a0688f6fad0a7665840ff69a0c /PKGBUILD
downloadaur-8449bbd7be6de2d3e6c313081d4ba81e41b88afa.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a43e01138ee0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Tobias Bachmann <tobachmann@gmx.de>
+pkgname=fsleyes-props
+pkgver=1.2.1
+pkgrel=1
+pkgdesc="The fsleyes-props project is an event programming framework, which includes the ability for automatic CLI generation and, optionally, automatic GUI generation (if wxPython is present). It is used by FSLeyes."
+arch=('any')
+url="https://fsl.fmrib.ox.ac.uk/fsl/fslwiki/FSLeyes"
+license=('Apache')
+groups=()
+depends=('python')
+makedepends=('python-six' 'python-numpy' 'python-matplotlib' 'python-deprecation' 'wxpython-phoenix' 'fslpy' 'fsleyes-widgets')
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+source=($pkgname-$pkgver.tar.gz::https://git.fmrib.ox.ac.uk/fsl/fsleyes/props/repository/archive.tar.gz?ref=$pkgver)
+sha256sums=('5d477dff63f35b5af38d0888bf63285ca14dc96deccb442609e19f251df8d250')
+
+package() {
+ cd "$srcdir/${pkgname#fsleyes-}-$pkgver-"*
+ python setup.py install --root="$pkgdir/" --optimize=1
+}