summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTobias Bachmann2018-05-14 11:55:42 +0200
committerTobias Bachmann2018-05-14 11:55:42 +0200
commitd13e7dca8f3d7da2c1293c7957ea85c7e30ebec5 (patch)
tree46f784d8cca8028838fdec4f1fb931be01fed6a7 /PKGBUILD
parent7aa21a1068beec9aeff6de24ea739a94a59ba6ae (diff)
downloadaur-d13e7dca8f3d7da2c1293c7957ea85c7e30ebec5.tar.gz
python-deprecation 2.x support
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0f6371f252fd..35cd03546239 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tobias Bachmann <tobachmann@gmx.de>
pkgname=fsleyes-props
pkgver=1.6.0
-pkgrel=1
+pkgrel=2
pkgdesc="The fsleyes-props project is an event programming framework, which includes the ability for automatic CLI generation and, optionally, automatic GUI generation (if wxPython is present). It is used by FSLeyes."
arch=('any')
url="https://fsl.fmrib.ox.ac.uk/fsl/fslwiki/FSLeyes"
@@ -18,5 +18,7 @@ sha256sums=('8b1dd13f0c193b6e7f758c2a59f74e7c703af1390f038474dec521ec3713f768')
package() {
cd "$srcdir/${pkgname#fsleyes-}-$pkgver-"*
+ # "Patching for deprecation 2.x support
+ sed -i 's/deprecation>=1\.\*,<=2\.\*/deprecation>=1\.\*/g' requirements.txt
python setup.py install --root="$pkgdir/" --optimize=1
}