summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTobias Bachmann2021-05-04 14:45:36 +0200
committerTobias Bachmann2021-05-04 14:45:36 +0200
commit17145dc6c647b66e3b0929e58d8327d984fb5d83 (patch)
tree2f7755a15e83f706a9580cdc34a3e1f966226a53 /PKGBUILD
parent773ba96d803e1471e6e17ab1442633b4bb793e9c (diff)
downloadaur-17145dc6c647b66e3b0929e58d8327d984fb5d83.tar.gz
Changed download URL
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 4 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 91fe3c47c44e..f87663903678 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tobias Bachmann <tobachmann@gmx.de>
pkgname=fsleyes-widgets
pkgver=0.12.1
-pkgrel=1
+pkgrel=2
pkgdesc="FSLeyes is the FSL image viewer, widgets is one of its dependent projects"
arch=('any')
url="https://fsl.fmrib.ox.ac.uk/fsl/fslwiki/FSLeyes"
@@ -13,14 +13,10 @@ optdepends=()
provides=()
conflicts=()
replaces=()
-source=($pkgname-$pkgver.tar.gz::https://git.fmrib.ox.ac.uk/fsl/fsleyes/widgets/repository/archive.tar.gz?ref=$pkgver)
-sha256sums=('35b100ec0668d75436de7c92b28cf1abd6a25beadc0bd4e76fd83090839ab43b')
+source=("https://git.fmrib.ox.ac.uk/fsl/fsleyes/${pkgname#fsleyes-}/-/archive/${pkgver}/${pkgname#fsleyes-}-${pkgver}.tar.gz")
+sha256sums=('3b97f5cdab9415b6cb3f2424a1e863f5576e86c886d6bf04cab2d26075ba38e4')
package() {
- cd "$srcdir/${pkgname#fsleyes-}-$pkgver-"*
- # "Patching" for deprecation 2.x support
- sed -i 's/deprecation>=1\.\*,<=2\.\*/deprecation>=1\.\*/g' requirements.txt
- # "Patching" for matplotlib>3 support
- sed -i 's/matplotlib>=1\.5,<3/matplotlib>=1\.5/g' requirements.txt
+ cd "$srcdir/${pkgname#fsleyes-}-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1
}