summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTobias Bachmann2018-05-14 11:55:32 +0200
committerTobias Bachmann2018-05-14 11:55:32 +0200
commit56c9a93745466eba06be2a5e7969563cfe82ba16 (patch)
treec13af67bec1ab7eb7c39286b087cc9005b565b2a /PKGBUILD
parent625100ce48426e611541a14613508a32c1fc48e4 (diff)
downloadaur-56c9a93745466eba06be2a5e7969563cfe82ba16.tar.gz
python-deprecation 2.x support
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7e9c2a2f7c14..23b68674085f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tobias Bachmann <tobachmann@gmx.de>
pkgname=fsleyes-widgets
pkgver=0.6.0
-pkgrel=1
+pkgrel=2
pkgdesc="FSLeyes is the FSL image viewer, widgets is one of its dependent projects"
arch=('any')
url="https://fsl.fmrib.ox.ac.uk/fsl/fslwiki/FSLeyes"
@@ -18,5 +18,7 @@ sha256sums=('03151fb5ace5d222c836d08e71dd099b8916b3fa5483030e55a60095cca021c2')
package() {
cd "$srcdir/${pkgname#fsleyes-}-$pkgver-"*
+ # "Patching" for deprecation 2.x support
+ sed -i 's/deprecation>=1\.\*,<=2\.\*/deprecation>=1\.\*/g' requirements.txt
python setup.py install --root="$pkgdir/" --optimize=1
}