summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCobalt Space2021-01-12 14:14:29 -0800
committerCobalt Space2021-01-12 14:14:29 -0800
commit5bb710e1b558c520734135836d806ec690a9f068 (patch)
tree569d1df51cd6e36a3980409456d6f95c45ffc411 /PKGBUILD
parent12816f44333d1b8cb36d07f0a762dd98f4c7bba5 (diff)
downloadaur-5bb710e1b558c520734135836d806ec690a9f068.tar.gz
bump to 202101041428-54016a89dc-release, add gitignore
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 333f6864cc00..539f69b2d23f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: William Brown <glowinthedarkcia@horsefucker.org>
-# Maintainer: Cobalt Space <cobaltspace@protonmail.com>
+# Maintainer: Cobalt Space <cobaltspace at protonmail dot com>
pkgname=ftba
-pkgver=202012101153_ce008c54b4
+pkgver=202101041428_54016a89dc_release
pkgrel=1
arch=(any)
pkgdesc="Offers many different styles of Minecraft modpacks to the community."
-source=("https://apps.modpacks.ch/FTBApp/release/${pkgver//_/-}-release/FTBA_linux_${pkgver//_/-}-release.deb" "ftbapp.desktop")
-sha256sums=('70c40e9db84b80679ddb919d7c62f576f3b8400654c3f46de40c98e8341b43a1'
+source=("https://apps.modpacks.ch/FTBApp/release/${pkgver//_/-}/FTBA_linux_${pkgver//_/-}.deb" "ftbapp.desktop")
+sha256sums=('10ab07df233eacc58dd3b43360f631c0c9636afe18b09acb8e90bcec23b8b437'
'72e6e0b01e790e416ab1ac215b7179f968156d10be5b36fad656a4f084778db6')
license=("LGPL2")
depends=("java-runtime=8" "java-runtime=11")
@@ -15,7 +15,13 @@ package() {
tar -xzf "$srcdir/data.tar.gz"
mkdir -p usr/{bin,share/applications}
cp "$srcdir/ftbapp.desktop" usr/share/applications
- rm -R opt/FTBA/{jre,bin/{ftbapp.app,{,**/}*.{exe,dll}}}
+
+ # remove windows and apple specific files
+ rm -R opt/FTBA/bin/{ftbapp.app,{,**/}*.{exe,dll}}
+
+ # remove bundled jre, java-runtime=11 is dependency.
+ rm -R opt/FTBA/jre
+
chmod +x opt/FTBA/bin/ftb-app
ln -rs ./opt/FTBA/FTBApp ./usr/bin
}