summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDan McCurry2017-04-21 15:45:46 -0400
committerDan McCurry2017-04-21 15:49:12 -0400
commitbfa1d4fd7eede10eec576f68e9d06f0e66a08500 (patch)
tree1171519d67fcdc381b9b74d2801cdbd9cb990e76 /PKGBUILD
parent765120c0a867c0f0bd6f774a078b052e2baf42f6 (diff)
downloadaur-bfa1d4fd7eede10eec576f68e9d06f0e66a08500.tar.gz
Updated version. Removed i686 compatibility as its no longer maintained
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 13 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e45fd1ec3ea5..b5ac5ec59511 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,27 @@
# Maintainer: Dan McCurry <dan.mccurry at linux dot com>
pkgname=fullprof-suite
-pkgver=2016.07
-pkgrel=2
+pkgver=2017.03
+pkgrel=1
pkgdesc="Crystallographic tools for Rietveld, profile matching & integrated intensity refinements of X-Ray and/or neutron data."
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://www.ill.eu/sites/fullprof"
license=('custom')
groups=('science')
-depends=('gcc-libs'
- 'openmotif')
+depends=('gcc-libs')
optdepends=('xterm: Needed to launch some programs from GUI')
provides=('fullprof')
conflicts=('fullprof')
install=${pkgname}.install
-source_i686=("https://www.ill.eu/sites/fullprof/downloads/FullProf_Suite_Oct2013_Lin.tgz")
-source_x86_64=("https://www.ill.eu/sites/fullprof/downloads/FullProf_Suite_July2016_Linux64.tgz")
-source=("fullprof-bin")
-noextract=("${source_i686[@]##*/}"
- "${source_x86_64[@]##*/}")
-md5sums=('0382c4e999d14ce61e9c1ca8571c86da')
-md5sums_i686=('db32eb6d3e9e7ef67dacbf42bd3b65d3')
-md5sums_x86_64=('d112d2c9ffac37b07a26fd4c3f300671')
-PKGEXT=.pkg.tar
-pkgver() {
- case $CARCH in
- i686) echo 2013.10;
- ;;
- x86_64) echo 2016.07;
- ;;
- *) error "Unsupported architecture.";
- ;;
- esac
-}
+# You will need to download the .tgz file from the webpage directly:
+# https://www.ill.eu/sites/fullprof/php/downloads.html
+
+source=("file://FullProf_Suite_March2017_Linux64.tgz"
+ "fullprof-bin")
+noextract=("${source##*/}")
+md5sums=('26e75738ffe284fb1399279c46f88391'
+ 'e91280ece6411983c74b3a8071402eb9')
+PKGEXT=.pkg.tar
prepare() {
mkdir -p ${srcdir}/${pkgname}
@@ -46,7 +35,6 @@ prepare() {
${srcdir}/fullprof-bin > ${srcdir}/bin/fullprof-$i
done
}
-
package() {
mkdir -p ${pkgdir}/opt/${pkgname}