diff options
author | Claudia Pellegrino | 2024-02-22 15:22:43 +0100 |
---|---|---|
committer | Claudia Pellegrino | 2024-02-22 15:22:43 +0100 |
commit | 9cec90220ce71a2370a7c76da4a075bc53cc4881 (patch) | |
tree | 676cdb68c37c69dd4b78689e76879967db2c8058 /PKGBUILD | |
parent | 7f765af154e27d0111b74a8370ead14e11685732 (diff) | |
download | aur-9cec90220ce71a2370a7c76da4a075bc53cc4881.tar.gz |
Include man page
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 12 |
1 files changed, 11 insertions, 1 deletions
@@ -2,7 +2,7 @@ pkgname=funiculi-git _gitpkgname=funiculi -pkgver=0.1.3.r7.c5a8945 +pkgver=0.1.3.r11.9cae3cf pkgrel=1 pkgdesc='Control your Denon AVR amplifier from the command line' arch=('any') @@ -18,7 +18,9 @@ makedepends=( 'git' 'python-build' 'python-installer' + 'python-myst-parser' 'python-poetry' + 'python-sphinx' 'python-wheel' ) provides=('funiculi') @@ -43,7 +45,11 @@ pkgver() { build() { cd "${srcdir}/${_gitpkgname}" + echo >&2 'Building wheel' python -m build --wheel --no-isolation + + echo >&2 'Generating man page' + sphinx-build -aqEW -b man doc/sphinx build/man } package() { @@ -59,4 +65,8 @@ package() { echo >&2 'Packaging the license' install -D -m 644 -t "${pkgdir}/usr/share/licenses/${pkgname}" \ 'LICENSE' + + echo >&2 'Packaging the man page' + install -D -m 644 -t "${pkgdir}/usr/share/man/man1" \ + build/man/*.1 } |