summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHarrison2022-01-23 23:22:44 -0500
committerHarrison2022-01-23 23:22:44 -0500
commit922a6eff23f26c6c00aecd34fd3d6684fc3691b9 (patch)
tree0d525563b06fa69ddd9eb8155017675d6006b2c5 /PKGBUILD
downloadaur-922a6eff23f26c6c00aecd34fd3d6684fc3691b9.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3771d7d4e237
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Harrison <htv04rules at gmail dot com>
+
+pkgname=funkin-rewritten
+pkgver=1.1.0_beta.2
+pkgrel=1
+pkgdesc="Optimized rewrite of Friday Night Funkin' built on LÖVE"
+arch=("any")
+url="https://github.com/HTV04/funkin-rewritten"
+license=("GPL3")
+depends=("love")
+makedepends=("git" "zip")
+source=("git+https://github.com/HTV04/funkin-rewritten.git"
+ "funkin-rewritten.sh"
+ "funkin-rewritten.desktop")
+sha256sums=("SKIP"
+ "073dc0138f7a3d4686f7a764ad98baf6e2d133de43ee199d8ccd562ba26490d5"
+ "7a069ea2dccc9e5eaa18f9415dce2fccb22ded8d0b3b8e89122866829b2ec046")
+
+build() {
+ # Build LOVE file
+ pushd "${srcdir}/funkin-rewritten" > /dev/null
+ make lovefile
+ popd > /dev/null
+}
+
+package() {
+ pushd "${srcdir}/funkin-rewritten" > /dev/null
+
+ # Install funkin-rewritten LOVE file
+ install -Dm0644 build/lovefile/funkin-rewritten.love "${pkgdir}/usr/share/${pkgname}/funkin-rewritten.love"
+
+ popd > /dev/null
+
+ # Install launcher script as binary
+ install -Dm0755 funkin-rewritten.sh "${pkgdir}/usr/bin/${pkgname}"
+
+ # Install desktop file
+ install -Dm0644 funkin-rewritten.desktop "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+}