summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrew Grechkin2023-11-24 23:00:26 +0100
committerAndrew Grechkin2023-11-24 23:00:26 +0100
commit3ff54e2c0d5015712d3507f3f41122f3bf6fd847 (patch)
tree03357e5e5d574297122e9befda4c3b0eaf16e4a4 /PKGBUILD
parent8a6c664f492739b2bef529568d6de5dd5dbeab20 (diff)
downloadaur-fuse3-p7zip-git.tar.gz
releate v1.2.1
* support --password * support --passfile
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5c48cb1cec32..5906315483d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,29 @@
# Maintainer: Andrew Grechkin <andrew.grechkin@gmail.com>
_name=fuse3-p7zip
pkgname="$_name-git"
-pkgver=1.2.0
-pkgrel=2
+pkgver=1.2.1
+pkgrel=1
pkgdesc="fuse3 file system that uses the p7zip library to mount archives"
arch=('x86_64')
url="https://github.com/andrew-grechkin/fuse3-p7zip"
license=('GPL')
depends=('fuse3' 'p7zip')
makedepends=('cmake' 'git' 'go-md2man')
-source=("git+https://github.com/andrew-grechkin/fuse3-p7zip#commit=1c7b2b4bac09f1c55add310874a624194fda2d58")
+source=("git+https://github.com/andrew-grechkin/fuse3-p7zip#commit=c7893da7fde1e610b09191586ee3ebbc2a4ff36b")
sha256sums=('SKIP')
prepare() {
- cd "$_name" || exit
+ cd "$_name"
git submodule update --init
}
pkgver() {
- cd "$_name" || exit
+ cd "$_name"
git describe --tags | sed 's/-/+/g'
}
build() {
- cd "$_name" || exit
+ cd "$_name"
cmake \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
@@ -33,7 +33,7 @@ build() {
}
package() {
- cd "$_name" || exit
+ cd "$_name"
make DESTDIR="$pkgdir" install -C "build-release"
install -Dm644 "${_name}.1" "$pkgdir/usr/share/man/man1/${_name}.1"
}