summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrew Grechkin2023-04-13 12:25:22 +0200
committerAndrew Grechkin2023-04-13 12:27:44 +0200
commit1936c6c2300eb075dc0659eb857e05578dc3e495 (patch)
treebff91cd746d34576848c3a55256870fded2fa300 /PKGBUILD
parentf69054cad7ccce86734f81e3481632809d8af13e (diff)
downloadaur-1936c6c2300eb075dc0659eb857e05578dc3e495.tar.gz
release v1.2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 207b1e692d88..b8a03825cf46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
_name=fuse3-p7zip
pkgname="$_name-git"
-pkgver=1.1.0
+pkgver=1.2.0
pkgrel=1
pkgdesc="fuse3 file system that uses the p7zip library to mount archives"
arch=('x86_64')
@@ -8,21 +8,21 @@ url="https://github.com/andrew-grechkin/fuse3-p7zip"
license=('GPL')
depends=('fuse3' 'p7zip')
makedepends=('cmake' 'go-md2man')
-source=("git+https://github.com/andrew-grechkin/fuse3-p7zip#commit=3b4431251efa1c18dc4e95ba15f36d546aafa3a8")
+source=("git+https://github.com/andrew-grechkin/fuse3-p7zip#commit=1c7b2b4bac09f1c55add310874a624194fda2d58")
sha256sums=('SKIP')
prepare() {
- cd "$_name"
+ cd "$_name" || exit
git submodule update --init
}
pkgver() {
- cd "$_name"
+ cd "$_name" || exit
git describe --tags | sed 's/-/+/g'
}
build() {
- cd "$_name"
+ cd "$_name" || exit
cmake \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
@@ -32,7 +32,7 @@ build() {
}
package() {
- cd "$_name"
+ cd "$_name" || exit
make DESTDIR="$pkgdir" install -C "build-release"
install -Dm644 "${_name}.1" "$pkgdir/usr/share/man/man1/${_name}.1"
}