summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorShadowKyogre2016-06-18 12:29:03 -0700
committerShadowKyogre2016-06-18 12:29:03 -0700
commitea5a89df564082dd4262cece64e44ac3bb6da93c (patch)
treec1206e865ca98e3b1f8c7287e6fab3bac5b4d5b2 /PKGBUILD
downloadaur-ea5a89df564082dd4262cece64e44ac3bb6da93c.tar.gz
First commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..275b8795ef65
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Sapphira Armageddos <shadowkyogre.public@gmail.com>
+# Contributor: Charles Bos <charlesbos1 AT gmail>
+# Contributor: Pantelis Panayiotou <p.panayiotou@gmail.com>
+# Contributor: Ronald van Haren <ronald.archlinux.org>
+# Contributor: nesl247 <nesl247@gmail.com>
+# Contributor: JJDaNiMoTh <jjdanimoth@gmail.com>
+
+_upstream=fusion-icon
+
+pkgname=fusion-icon-git
+epoch=1
+pkgver=0.2.2.r10.gb6fb51a
+pkgrel=1
+pkgdesc="Simple tray icon for Compiz 0.8"
+arch=('any')
+url="http://www.compiz.org/"
+license=('GPL')
+conflicts=('fusion-icon0.9' 'fusion-icon')
+provides=('fusion-icon')
+depends=('compizconfig-python' 'hicolor-icon-theme' 'xorg-utils' 'mesa-demos')
+
+# Note to anyone who builds this: Make sure you install the appropriate
+# dependencies for the user interfaces you want to use! Otherwise, it'll appear
+# like it's not working!
+optdepends=(
+ 'python-pyqt5: For the Qt Interface'
+ 'python-gobject: For the GTK+ Interface'
+ 'libappindicator-gtk3: For the GTK+ Interface'
+)
+
+install="$pkgname.install"
+source=("git+https://github.com/compiz-reloaded/${_upstream}")
+
+pkgver() {
+ cd "${srcdir}/${_upstream}"
+ git describe --long --tags|sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/${_upstream}"
+ # Workaround until upstream autofills out main.py for each interface
+ make PREFIX=/usr
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
+
+sha256sums=('SKIP')