summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMikael Blomstrand2020-04-24 08:22:38 +0200
committerMikael Blomstrand2020-04-24 08:22:38 +0200
commitc5e1df80c5e654727ec82457b0b296a81d9a242e (patch)
tree5eab84372868b0b9678bfc429792254ca1092876 /PKGBUILD
parent424ad383ac1202fdeeedc5ec427e6a318a931d9a (diff)
downloadaur-c5e1df80c5e654727ec82457b0b296a81d9a242e.tar.gz
commit-id now contains output from `git describe`!
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 55f14bec7b9a..19ca9090cd8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Olaf Leidinger <oleid@mescharet.de>
pkgname=futhark-nightly
-pkgver=0.14.0.rf13eb89
+pkgver=0.15.5.r5.gf59a43a58
pkgrel=1
pkgdesc="A data-parallel functional programming language"
arch=('x86_64')
@@ -17,12 +17,13 @@ optdepends=('opencl-headers: opencl support'
makedepends=()
provides=("${pkgname%-nightly}")
conflicts=("${pkgname%-nightly}")
-source=("${pkgname}-$(date -u +%Y%m%d%H).tar.xz::https://futhark-lang.org/releases/futhark-nightly-linux-${arch}.tar.xz")
+_timestamp=$(date -u +%Y%m%d%H)
+source=("${pkgname}-${_timestamp}.tar.xz::https://futhark-lang.org/releases/futhark-nightly-linux-${arch}.tar.xz")
sha256sums=(SKIP)
pkgver() {
cd "${srcdir}/futhark-nightly-linux-${arch}"
- printf "%s.r%s" "$(./bin/futhark -V | grep Futhark | sed "s/Futhark //")" "$(cat commit-id)"
+ sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' < commit-id
}
package() {