summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
author0x9fff002020-02-08 15:32:16 +0100
committer0x9fff002020-02-08 15:32:16 +0100
commit8dd0441b65173c0812b029459d6745919430a89b (patch)
tree7f849dcde7f5695b8de7230277e4b27b374934c7 /PKGBUILD
parent1d94bff4d68e185e8097445118a90840eeaa7514 (diff)
downloadaur-8dd0441b65173c0812b029459d6745919430a89b.tar.gz
update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 22 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 79eda0e872b6..31296d40fd3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,42 @@
# Maintainer: 0x9fff00 <0x9fff00+git@protonmail.ch>
-pkgname=futurerestore-s0uthwest-git
-_pkgname=futurerestore
-pkgver=r230.8e00751
-pkgrel=4
+
+_name=futurerestore
+_forkname=$_name-s0uthwest
+pkgname=$_forkname-git
+pkgver=r248.08d0e00
+pkgrel=5
pkgdesc="iOS upgrade and downgrade tool utilizing SHSH blobs - s0uthwest's fork - git version"
arch=('x86_64')
-url="https://github.com/s0uthwest/futurerestore"
+url="https://github.com/s0uthwest/$_name"
license=('LGPL3')
-depends=('libplist' 'libzip' 'libimobiledevice' 'libfragmentzip' 'libirecovery' 'libusbmuxd' 'curl' 'openssl' 'zlib' 'lzfse')
-makedepends=('git')
-provides=('futurerestore' 'futurerestore-s0uthwest')
-conflicts=('futurerestore')
-source=('git+https://github.com/s0uthwest/futurerestore.git'
- 'git+https://github.com/s0uthwest/img4tool.git'
- 'git+https://github.com/s0uthwest/tsschecker.git'
+depends=('libplist' 'libzip' 'libimobiledevice' 'libfragmentzip' 'libirecovery' 'curl' 'openssl' 'zlib')
+makedepends=('git' 'lzfse')
+provides=("$_name" "$_forkname")
+conflicts=("$_name")
+source=("git+$url.git"
+ 'git+https://github.com/s0uthwest/img4tool-old.git'
+ 'git+https://github.com/tihmstar/tsschecker.git'
'git+https://github.com/s0uthwest/idevicerestore.git'
'git+https://github.com/tihmstar/jssy.git'
'idevicerestore-0001-configure.ac-check-for-pthreads.patch')
-sha512sums=('SKIP'
+sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'eb412d9b814a8d94e6f716e82559f5d5e31b5ca5267b8e28c47d72d09312ea138f448785a3f39e8798d2cd15b9f65168fda39a21ea465274d32b3b24a979ed91')
+ '621e0e9bd2a31d8be8da59c051d2190a98be0f5c4cd5158225ffd4ff91d3ab1e')
pkgver() {
- cd "$_pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$_name"
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
- cd "$_pkgname"
+ cd "$_name"
git submodule deinit -f --all
git submodule init
- git config submodule.external/img4tool.url "$srcdir/img4tool"
+ git config submodule.external/img4tool.url "$srcdir/img4tool-old"
git config submodule.external/tsschecker.url "$srcdir/tsschecker"
git config submodule.external/idevicerestore.url "$srcdir/idevicerestore"
git submodule update
@@ -53,7 +55,7 @@ prepare() {
}
build() {
- cd "$_pkgname"
+ cd "$_name"
CFLAGS+=' -DIDEVICERESTORE_NOMAIN=1 -DIMG4TOOL_NOMAIN=1 -DTSSCHECKER_NOMAIN=1'
./autogen.sh --prefix=/usr
@@ -61,7 +63,7 @@ build() {
}
package() {
- cd "$_pkgname"
+ cd "$_name"
make DESTDIR="$pkgdir/" install
}