summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
author0x9fff002020-02-08 19:03:56 +0100
committer0x9fff002020-02-08 19:03:56 +0100
commitbdbf95e757626465108ea16d2ce75eb3cf8f1b3e (patch)
treefb64211845396a58261646e05feb5932e3aac062 /PKGBUILD
parent8dd0441b65173c0812b029459d6745919430a89b (diff)
downloadaur-bdbf95e757626465108ea16d2ce75eb3cf8f1b3e.tar.gz
Add patches
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 16 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 31296d40fd3a..13bc6650d70f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _name=futurerestore
_forkname=$_name-s0uthwest
pkgname=$_forkname-git
pkgver=r248.08d0e00
-pkgrel=5
+pkgrel=6
pkgdesc="iOS upgrade and downgrade tool utilizing SHSH blobs - s0uthwest's fork - git version"
arch=('x86_64')
url="https://github.com/s0uthwest/$_name"
@@ -18,12 +18,16 @@ source=("git+$url.git"
'git+https://github.com/tihmstar/tsschecker.git'
'git+https://github.com/s0uthwest/idevicerestore.git'
'git+https://github.com/tihmstar/jssy.git'
+ 'img4tool-0001-Include-arpa-inet.h-header.patch'
+ 'tsschecker-0001-Fix-incorrect-language-standard.patch'
'idevicerestore-0001-configure.ac-check-for-pthreads.patch')
sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'bd9c4dc74f56a26d9aef10938fe0fb58cdec268a80a04b217dd4a32c5b60db2d'
+ '3fcde7558ae9f5ebfa930a2b02074251a6817e2a984c8d0e18113baa0ea708a5'
'621e0e9bd2a31d8be8da59c051d2190a98be0f5c4cd5158225ffd4ff91d3ab1e')
pkgver() {
@@ -41,8 +45,8 @@ prepare() {
git config submodule.external/idevicerestore.url "$srcdir/idevicerestore"
git submodule update
- cd external/idevicerestore
- for p in "$srcdir"/idevicerestore-*.patch; do
+ cd external/img4tool
+ for p in "$srcdir"/img4tool-*.patch; do
patch -Np1 -i "$p"
done
cd ../..
@@ -51,6 +55,15 @@ prepare() {
git submodule init
git config submodule.external/jssy.url "$srcdir/jssy"
git submodule update
+ for p in "$srcdir"/tsschecker-*.patch; do
+ patch -Np1 -i "$p"
+ done
+ cd ../..
+
+ cd external/idevicerestore
+ for p in "$srcdir"/idevicerestore-*.patch; do
+ patch -Np1 -i "$p"
+ done
cd ../..
}