summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNick2018-01-21 16:26:41 -0500
committerNick2018-01-21 16:26:41 -0500
commit16ea8e5e8e20f663d1413b3421310a106b7f6d74 (patch)
treefa7a3069bda84e6aaf22d6eaec2ef96204d38d5c /PKGBUILD
parent12712b7f142ba905b30f73747b9430762ae70b99 (diff)
downloadaur-16ea8e5e8e20f663d1413b3421310a106b7f6d74.tar.gz
Using pkgver() to auto-update now, so this won't look out of date.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ad2d640fc899..c665f3ee040c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,11 @@
# Maintainer: Nick Levesque <nick.levesque@gmail.com>
# Contributor: Kevin Hanselman <kevin-hanselman@gmail.com>
pkgname=fwup-git
-pkgver=0.19.0
+pkgver=v0.19.0.r5.ga107d81
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
pkgrel=1
pkgdesc="Configurable embedded Linux firmware update creator and runner"
arch=('any')