summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBaltazár Radics2021-11-22 18:14:13 +0100
committerBaltazár Radics2021-11-22 18:14:13 +0100
commite9b555de8e6a8e60e5c3fd7c4aab7babad856370 (patch)
treeaa17b985b6dc0072ff2c639b1784a9ef863611c6 /PKGBUILD
downloadaur-e9b555de8e6a8e60e5c3fd7c4aab7babad856370.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4bef11543f5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Baltazár Radics <baltazar.radics@gmail.com>
+pkgname=fxlibc-gint
+pkgver=1.2.2
+pkgrel=1
+pkgdesc='A C standard library for fx Casio calculators, for use with gint'
+arch=(x86_64)
+url='https://gitea.planet-casio.com/Vhex-Kernel-Core/fxlibc'
+license=(CCPL)
+makedepends=(cmake sh-elf-gcc-casio)
+options=(!strip)
+source=(fxlibc-$pkgver.tar.gz::https://gitea.planet-casio.com/Vhex-Kernel-Core/fxlibc/archive/$pkgver.tar.gz)
+sha256sums=('9891fe9a45c5e36d1c8d21f8267c342cc092f35783ad0cb48bb2b82cfe66def2')
+
+build() {
+ mkdir -p build
+ cd build
+ # based on default makepkg.conf (remove incompatible flags)
+ CFLAGS='-O2 -pipe -fno-plt -Wp,-D_FORTIFY_SOURCE=2 -Wformat -Werror=format-security'
+ CXXFLAGS="$CFLAGS -Wp,-D_GLIBCXX_ASSERTIONS"
+ LDFLAGS='-Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now'
+ cmake -DFXLIBC_TARGET=gint -DCMAKE_TOOLCHAIN_FILE=cmake/toolchain-sh.cmake ../fxlibc
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}