summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTaiki Sugawara2023-01-02 23:19:08 +0900
committerTaiki Sugawara2023-01-02 23:19:08 +0900
commit513d730fdf76efe8b8c557b948e8243cd993767d (patch)
tree6e5929799da37567eabaef3f96da179b3a262aff /PKGBUILD
parentbec7208b932860bf1d34a032fa3ecbb5ebb7d14e (diff)
downloadaur-513d730fdf76efe8b8c557b948e8243cd993767d.tar.gz
follow-up Rust package guidelines
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c8921cb37c62..10615f5cf5cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ url="https://github.com/lincheney/fzf-tab-completion"
license=('GPL3')
depends=('fzf')
optdepends=('rl_custom_function: readline support')
-makedepends=('rust' 'cargo')
+makedepends=('cargo')
provides=("$_pkgname")
install=$pkgname.install
source=("$_pkgname::git+https://github.com/lincheney/$_pkgname.git")
@@ -22,12 +22,15 @@ pkgver() {
build() {
cd "$srcdir/$_pkgname"
- (cd readline && cargo build --release)
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ (cd readline && cargo build --release --locked)
}
check() {
cd "$srcdir/$_pkgname"
- (cd readline && cargo test --release)
+ export RUSTUP_TOOLCHAIN=stable
+ (cd readline && cargo test --frozen)
}
package() {