summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatMoul2023-01-14 23:04:42 +0100
committerMatMoul2023-01-14 23:04:42 +0100
commit8a49211abdf17638bfd9ff8df6069892013a4b7b (patch)
tree3d6d6ed00a15a7b11bf4a25e8ef8c99a98da2329 /PKGBUILD
parent2166d4fe9c889d6a1f3082964013513b9ead3bf0 (diff)
downloadaur-g810-led-git.tar.gz
Version 0.4.3.r1.efa3c35-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD63
1 files changed, 33 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6d5da59366a4..8c0be2d8ecb5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,51 @@
-# Maintainer: MatMoul <matmoul@gmail.com>
+# Maintainer: MatMoul <matmoul at the google email domain which is .com>
+
+_githubuser=matmoul
+_githubrepo=g810-led
+_gitcommit=efa3c35e74f01a2ed2346320da8bad411bfe8ed8
pkgname=g810-led-git
-_appname=g810-led
-_gitname=g810-led
-pkgver=0.4.3
+pkgver=0.4.3.r1.efa3c35
pkgrel=1
-pkgdesc="Linux led controller for Logitech G213, G410, G413. G512, G513, G610, G810, G815, G910 and GPRO Keyboards"
+pkgdesc='Linux led controller for Logitech G213, G410, G413. G512, G513, G610, G810, G815, G910 and GPRO Keyboards'
arch=('any')
-url="https://github.com/MatMoul/g810-led"
+url="https://github.com/${_githubuser}/${_githubrepo}"
license=('GPL3')
depends=('hidapi')
-makedepends=('git' 'gcc' 'make')
+makedepends=('git' 'systemd')
optdepends=('libusb: old implementation, for developpers')
-install=${pkgname}.install
-provides=("g213-led=${pkgver}" "g410-led=${pkgver}" "g413-led=${pkgver}" "g512-led=${pkgver}" "g513-led=${pkgver}" "g610-led=${pkgver}"
-"g810-led=${pkgver}" "g815-led=${pkgver}" "g910-led=${pkgver}" "gpro-led=${pkgver}")
-backup=("etc/${_appname}/profile" "etc/${_appname}/reboot" "etc/udev/rules.d/${_appname}.rules")
-options=(!emptydirs)
-source=("git+https://github.com/MatMoul/${_appname}.git")
-#source=("git://github.com/MatMoul/${_appname}.git#branch=")
-md5sums=('SKIP')
+install="${pkgname}.install"
+provides=("g213-led=${pkgver}"
+ "g410-led=${pkgver}"
+ "g413-led=${pkgver}"
+ "g512-led=${pkgver}"
+ "g513-led=${pkgver}"
+ "g610-led=${pkgver}"
+ "g810-led=${pkgver}"
+ "g815-led=${pkgver}"
+ "g910-led=${pkgver}"
+ "gpro-led=${pkgver}")
+backup=("etc/${_githubrepo}/profile" "etc/${_githubrepo}/reboot" "etc/udev/rules.d/${_githubrepo}.rules")
+source=("git+https://github.com/${_githubuser}/${_githubrepo}.git#commit=${_gitcommit}")
+sha256sums=('SKIP')
build() {
- cd ${_gitname}
-
- # build with hidapi :
+ cd "${_githubrepo}"
make bin
-
- # build with libusb :
- # make bin LIB=libusb
}
package() {
- cd ${_gitname}
+ cd "${_githubrepo}"
make DESTDIR="${pkgdir}" setup
- mkdir -p ${pkgdir}/usr/share/licenses/${pkgname}
- cp LICENSE ${pkgdir}/usr/share/licenses/${pkgname}
- cp ${pkgdir}/etc/${_appname}/samples/group_keys ${pkgdir}/etc/${_appname}/profile
- cp ${pkgdir}/etc/${_appname}/samples/all_off ${pkgdir}/etc/${_appname}/reboot
+ mkdir -p ${pkgdir}/usr/share/licenses/${_githubrepo}
+ cp LICENSE ${pkgdir}/usr/share/licenses/${_githubrepo}
+ cp ${pkgdir}/etc/${_githubrepo}/samples/group_keys ${pkgdir}/etc/${_githubrepo}/profile
+ cp ${pkgdir}/etc/${_githubrepo}/samples/all_off ${pkgdir}/etc/${_githubrepo}/reboot
chmod -R 755 ${pkgdir}/etc
chmod -R 755 ${pkgdir}/usr
- chmod -R 644 ${pkgdir}/etc/${_appname}/samples/*
- chmod 644 ${pkgdir}/etc/udev/rules.d/${_appname}.rules
+ chmod -R 644 ${pkgdir}/etc/${_githubrepo}/samples/*
+ chmod 644 ${pkgdir}/etc/udev/rules.d/${_githubrepo}.rules
chmod 644 ${pkgdir}/usr/lib/systemd/system/*
- chmod 755 ${pkgdir}/usr/share/licenses/${pkgname}
- chmod 644 ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ chmod 755 ${pkgdir}/usr/share/licenses/${_githubrepo}
+ chmod 644 ${pkgdir}/usr/share/licenses/${_githubrepo}/LICENSE
}