summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatMoul2017-01-26 02:59:32 +0100
committerMatMoul2017-01-26 02:59:32 +0100
commit1f5a5bac7579947ec2a9245c8bd3e0ec9f14e614 (patch)
treed1c1d8a699afa10b1d3666c02897c9e2ced470ca /PKGBUILD
parent9bbfda11c5bc3c33ec66a49c2eb0be17d58f6152 (diff)
downloadaur-1f5a5bac7579947ec2a9245c8bd3e0ec9f14e614.tar.gz
New version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 66f4b17e96f9..215021acf229 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@ pkgname=g810-led-git
_appname=g810-led
_gitname=g810-led
pkgver=0.0.1
-pkgrel=3
+pkgrel=4
pkgdesc="Linux led controller for Logitech G410, G610, G810 and G910 Keyboards"
arch=('i686' 'x86_64')
url="https://github.com/MatMoul/g810-led"
license=('GPL3')
depends=('hidapi')
makedepends=('git' 'gcc' 'make')
-optdepends=('libusb: slower, old implementation, use only if you have problem with hidapi')
+optdepends=('libusb: old implementation, use only if you have problem with hidapi')
conflicts=('g810-led')
install=${pkgname}.install
provides=("g410-led=${pkgver}" "g610-led=${pkgver}" "g810-led=${pkgver}" "g910-led=${pkgver}")
@@ -33,6 +33,8 @@ build() {
package() {
cd ${_gitname}
make DESTDIR="${pkgdir}" setup
+ mkdir -p ${pkgdir}/usr/share/licenses/${pkgname}
+ cp LICENSE ${pkgdir}/usr/share/licenses/${pkgname}
cp ${pkgdir}/etc/${_appname}/samples/group_keys ${pkgdir}/etc/${_appname}/profile
cp ${pkgdir}/etc/${_appname}/samples/all_off ${pkgdir}/etc/${_appname}/reboot
chmod -R 755 ${pkgdir}/etc
@@ -40,4 +42,6 @@ package() {
chmod -R 644 ${pkgdir}/etc/${_appname}/*
chmod 644 ${pkgdir}/etc/udev/rules.d/${_appname}.rules
chmod 644 ${pkgdir}/usr/lib/systemd/system/*
+ chmod 755 ${pkgdir}/usr/share/licenses/${pkgname}
+ chmod 644 ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}