summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjose17112018-05-21 22:12:04 +0200
committerjose17112018-05-21 22:12:04 +0200
commit192075a74f54b88c35b87d73cde9c9df80d0cf5b (patch)
treef43a87f21a5875c27ca03758d897f493c35f545b /PKGBUILD
downloadaur-192075a74f54b88c35b87d73cde9c9df80d0cf5b.tar.gz
Adopted from aur3 (+ updated & fixed)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f4896cd93e4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Nathan Owe <ndowens.aur at gmail dot com>
+# Maintainer: Jose Riha <jose1711 gmail com>
+
+pkgname=gadmin-bind
+pkgver=0.2.8
+pkgrel=1
+pkgdesc="A GTK+ Application to help administrate BIND"
+arch=('i686' 'x86_64')
+url="http://dalalven.dtdns.net/linux/gadmintools-webpage/app_pages/gadmin-bind.html"
+license=('GPL')
+depends=('gtk3' 'bind')
+optdepends=('gksu: Graphical SU Support')
+source=("http://dalalven.dtdns.net/linux/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ "${pkgname}-menu"
+ "${pkgname}.desktop"
+ )
+md5sums=('ae4686c0417ac542b54aaf6d7a76d893'
+ '8705c6ad45bdd08022cef2de4cd8bbc7'
+ '0fd7b067494e1edef07a9ec5a8a38643')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install sbindir=/usr/bin
+ install -m644 -D $srcdir/gadmin-bind.desktop $pkgdir/usr/share/applications/gadmin-bind.desktop
+ install -m755 $srcdir/gadmin-bind-menu $pkgdir/usr/bin/gadmin-bind-menu
+}