summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAmir MOHAMMADI2019-12-05 10:54:07 +0100
committerAmir MOHAMMADI2019-12-05 10:54:07 +0100
commit042bcfac8e0426fa4bd39ef41200ef7e2113b78f (patch)
tree6f61ab3a1dd8c52bd5cd74887e3f8ed0f8016520 /PKGBUILD
parentd8de875b2e6dbd9ad7420d954c378cc6192d34dc (diff)
downloadaur-042bcfac8e0426fa4bd39ef41200ef7e2113b78f.tar.gz
update to 5.0.0.rc1
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD21
1 files changed, 10 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 015f2c15cc9d..475ffebf3db8 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Amir Mohammadi <183.amir@gmail.com>
pkgname=gahshomar
-pkgver=4.4.1
+pkgver=5.0.0.rc1
pkgrel=0
pkgdesc="A Persian (Jalali/Farsi) calendar"
arch=(i686 x86_64)
@@ -8,21 +8,20 @@ url="https://gahshomar.github.io/gahshomar/"
license=('GPL3')
replaces=('persian-calendar')
conflicts=('persian-calendar')
-depends=('python-gobject' 'jcal-git' 'libpeas')
-makedepends=('intltool' 'yelp-tools' 'gnome-common' 'gobject-introspection')
-optdepends=('libappindicator-gtk3: for the app indicator plugin'
- 'gnome-shell: for the gnome-shell extension')
+depends=('python-gobject' 'libappindicator-gtk3')
+makedepends=('meson' 'intltool' 'yelp-tools' 'gnome-common' 'gobject-introspection')
+optdepends=('gnome-shell: for the gnome-shell extension')
install=gahshomar.install
-source=($pkgname-$pkgver.tar.gz::https://github.com/Gahshomar/gahshomar/releases/download/v$pkgver/gahshomar-$pkgver.tar.gz)
-md5sums=('e268babec06a94ca90c7240a889e875e')
+source=($pkgname-$pkgver.tar.gz::https://github.com/Gahshomar/gahshomar/archive/v$pkgver.tar.gz)
+md5sums=('1556d5a7277c17c70fe11b661a1415f0')
build() {
cd $srcdir/$pkgname-$pkgver
- ./configure --prefix=/usr --disable-schemas-compile
- make
+ meson --prefix /usr --buildtype=plain . build
+ ninja -C build
}
package() {
- cd $srcdir/$pkgname-$pkgver
- make DESTDIR="${pkgdir}" install
+ cd $srcdir/$pkgname-$pkgver
+ DESTDIR="$pkgdir" ninja -C build install
}