summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSefa Eyeoglu2019-06-06 18:13:17 +0200
committerSefa Eyeoglu2019-06-06 18:13:17 +0200
commit6a952a6f6526f728fb4cfa09754ec192c3a4c682 (patch)
tree8ef4679ffa48d92f6b1449da15cac75d70ea72f2 /PKGBUILD
parent016e23d95e1ef8f878c58ae57728cd1e6b3b144d (diff)
downloadaur-6a952a6f6526f728fb4cfa09754ec192c3a4c682.tar.gz
upgpkg: gaia-hub 2.5.3-2
Fix default storage folder permissions
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 25 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5a7514011255..bbf8a3039741 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,6 +16,8 @@ makedepends=(
"npm"
"node-gyp"
"make"
+ "typescript"
+ "ts-node"
)
optdepends=(
"nginx: utilize provided example configs"
@@ -23,12 +25,16 @@ optdepends=(
source=(
"${pkgname}::git+https://github.com/blockstack/gaia.git#tag=v${pkgver}"
- "gaia-hub.service"
"config.json"
+ "service"
+ "sysusers"
+ "tmpfiles"
)
sha512sums=('SKIP'
- '26297bc8e85b7577922442dc904597d7087e52e1204580a7c1ede516de9b9947e6e1640f28aa4bc03851c466bc9953dd256c39ac7f429db62ea9ba662eb14a0f'
- '19a037b067cd254cf7c06b517b6a696804f9a559fa6689ca65478f963d3dfc28a03598ecc9c3cede60699dd29b691cefeea2b98e283fcca443cc8eb4dc17aad7')
+ '54c7b8e5cec9930f09541b8a5ea62971693206cc19b33f94301a9a27e4a61865f235000a30d62e93f4c399654abac0e8f7f4ee388f982f873eaffea0a011ccbd'
+ '9932bc1cad558cf86f107b3069e81d4034d6c3fced6d94af899da25b7309806efcc2d2a52572a3b755c893278fd440ac6ee6b723fb8ce736bd51968096138736'
+ '34c7aee63c3dc87f608019489441be0fc06299fc802d1b5d587f92f7d6c515daa384911458f7bef7db8c927e4c960052567e7b176e70e882a604776ff3b82257'
+ 'a71bae7d8f0e449a4bc9ea97d5f3db71c2e3511a25f6004f047b0fb2847f3490487acaf9bc9ea58b3fb71405c5172745543b3348e463a11d049e49d2ea2f7d0a')
prepare() {
cd "$srcdir/$pkgname/hub"
@@ -36,6 +42,8 @@ prepare() {
}
build() {
+ export NODE_ENV="production"
+
cd "$srcdir/$pkgname/hub"
npm run build
}
@@ -43,25 +51,36 @@ build() {
package() {
cd "$srcdir/$pkgname/hub"
- export NODE_ENV="production"
- install -d "${pkgdir}/etc/gaia/hub" "${pkgdir}/usr/lib/node_modules/gaia-hub" "${pkgdir}/usr/bin" "${pkgdir}/srv/gaia/hub"
+ install -d "${pkgdir}/etc/gaia/hub" "${pkgdir}/usr/lib/node_modules/gaia-hub" "${pkgdir}/usr/bin"
+ # Install data
cp -r "lib" "node_modules" "${pkgdir}/usr/lib/node_modules/gaia-hub/"
chmod 755 "${pkgdir}/usr/lib/node_modules/gaia-hub/lib/index.js"
+ # link executable
ln -s "/usr/lib/node_modules/gaia-hub/lib/index.js" "${pkgdir}/usr/bin/gaia-hub"
+ # install custom default config
install -Dm 644 "${srcdir}/config.json" "${pkgdir}/usr/lib/node_modules/gaia-hub/config.json"
ln -s "/usr/lib/node_modules/gaia-hub/config.json" "${pkgdir}/etc/gaia/hub/config.json"
+ # install examples
install -Dm 644 "nginx.conf" "${pkgdir}/usr/share/doc/gaia/hub/nginx.conf.example"
for file in etc/*.json; do
install -m 644 "$file" "${pkgdir}/usr/share/doc/gaia/hub/"
done
+ # install documentation and license
install -Dm 644 "README.md" "${pkgdir}/usr/share/doc/gaia/hub/README.md"
install -Dm 644 "CHANGELOG.md" "${pkgdir}/usr/share/doc/gaia/hub/CHANGELOG.md"
install -Dm 644 "../LICENSE" "${pkgdir}/usr/share/licenses/gaia/LICENSE"
- install -Dm 644 "${srcdir}/gaia-hub.service" "${pkgdir}/usr/lib/systemd/system/gaia-hub.service"
+ # Install sysusers
+ install -Dm644 "$srcdir/sysusers" "$pkgdir/usr/lib/sysusers.d/${pkgname}.conf"
+
+ # Install tmpfiles
+ install -Dm644 "$srcdir/tmpfiles" "$pkgdir/usr/lib/tmpfiles.d/${pkgname}.conf"
+
+ # install service
+ install -Dm 644 "${srcdir}/service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
}