summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxime “pep” Buquet2023-01-31 19:16:34 +0100
committerMaxime “pep” Buquet2023-01-31 19:16:34 +0100
commit49e83c3af1812335768ca358c01b25ea7adca431 (patch)
tree12b9d7452d164875c08e143e4a773b0622e855ad /PKGBUILD
parent6b8d122080f8e1866ded37f4ed9fda69b6a9eefc (diff)
downloadaur-49e83c3af1812335768ca358c01b25ea7adca431.tar.gz
Package metadata
Signed-off-by: Maxime “pep” Buquet <pep@bouah.net>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2f483d5f8cde..09c44d97c019 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ _name=gajim
pkgname="$_name-git"
epoch=1
pkgver=r20795.56ad85842
-pkgrel=1
+pkgrel=2
pkgdesc="Jabber/XMPP instant messenger client written in Python with GTK+"
arch=('any')
url="https://gajim.org/"
@@ -54,9 +54,11 @@ pkgver() {
build() {
cd $_name
python -m build --wheel --no-isolation
+ ./pep517build/build_metadata.py -o dist/metadata
}
package() {
cd $_name
python -m installer --destdir="$pkgdir" dist/*.whl
+ ./pep517build/install_metadata.py --prefix="$pkgdir/usr" dist/metadata
}