summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot2019-12-22 13:39:56 +0100
committerEmmanuel Gil Peyrot2019-12-22 13:39:56 +0100
commite66226d99aa8689e63b557b9c83d6dfe5686c0b6 (patch)
treed2863acbefe74f56a620d510164e33b31ffa2e1d /PKGBUILD
parentd346c5d8596dba46175ed7df408bd209e840861c (diff)
downloadaur-e66226d99aa8689e63b557b9c83d6dfe5686c0b6.tar.gz
Change the versioning scheme
The latest tag on master had been gajim-1.0.0-beta1 for years, it was confusing users, so now we ignore the tag and count from the very first commit instead. Bump epoch too so that pacman doesn’t think this is a downgrade.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b650c97591ef..5664daeca7b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,8 @@
_name=gajim
pkgname="$_name-git"
-pkgver=1.0.0.beta1.r1944.g9497dce25
+epoch=1
+pkgver=r17041.9497dce25
pkgrel=1
pkgdesc="Jabber/XMPP instant messenger client written in Python with GTK+"
arch=('any')
@@ -43,7 +44,7 @@ md5sums=('SKIP')
pkgver() {
cd $_name
- git describe --long --tags | sed 's/^gajim-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {