summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJaroslav Lichtblau2015-08-09 22:42:01 +0200
committerJaroslav Lichtblau2015-08-09 22:42:01 +0200
commit10eb4b9d520d4b31416db46538853fc4cc7244a1 (patch)
tree9d2d5bb8d3235eafb0ceb454efb93ad22fc72658 /PKGBUILD
parent20e00ee06cce8495eb03e453f4c6508b8d11ba37 (diff)
downloadaur-10eb4b9d520d4b31416db46538853fc4cc7244a1.tar.gz
galapix googlecode update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 74399537b591..fca1d063cc93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,30 +5,30 @@ pkgver=0.2.1
pkgrel=1
pkgdesc="A zoomable image viewer for large collections of images"
arch=('i686' 'x86_64')
-url="http://code.google.com/p/galapix/"
+url="https://github.com/Galapix/galapix"
license=('GPL3')
depends=('curl' 'glew' 'imagemagick' 'libexif' 'libjpeg' 'libpng' 'mesa' 'sdl' 'sqlite3')
makedepends=('scons' 'patch' 'gtkglextmm' 'libglademm' 'boost')
optdepends=('xcftools: XCF format support'
'gimp-ufraw: RAW format support')
-source=(http://galapix.googlecode.com/archive/$pkgname-$pkgver.tar.gz
+source=($pkgname-$pkgver.tar.gz::https://github.com/Galapix/galapix/archive/v$pkgver.tar.gz
imagemagick_plugin.patch png_string_fix.patch)
-md5sums=('SKIP'
+md5sums=('7a7df7812a0c45e12273ace0c7c4ed48'
'9f2397caa6bea257ca0cd09a31f96dbf'
'34f0386d3247edc62e3ff4e55892d286')
prepare() {
- cd "${srcdir}"/$pkgname-$pkgname-$pkgver
+ cd "${srcdir}"/$pkgname-$pkgver
patch -Np0 -i "${srcdir}"/imagemagick_plugin.patch
patch -Np0 -i "${srcdir}"/png_string_fix.patch
}
build() {
- cd "${srcdir}"/$pkgname-$pkgname-$pkgver
+ cd "${srcdir}"/$pkgname-$pkgver
scons
}
package() {
- cd "${srcdir}"/$pkgname-$pkgname-$pkgver
+ cd "${srcdir}"/$pkgname-$pkgver
install -Dm755 build/$pkgname.sdl "${pkgdir}"/usr/bin/$pkgname
}