summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFernando Ortiz2020-03-21 01:51:08 -0500
committerFernando Ortiz2020-03-21 01:51:08 -0500
commitc34a6bf509fa31ccf4b0710020b4ae543839f044 (patch)
tree056d9ca1dfcbc76e4dc5d41c878b5f00bfe82465 /PKGBUILD
parentde7f1c9de2f65e3b21eff96bdae65d5e992ab1e8 (diff)
downloadaur-gale-git.tar.gz
new changes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 49788b0aad04..d72887465477 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,25 +4,25 @@
_pkgname=gale
pkgname=gale-git
epoch=1
-pkgver=1.1.r17.gaa4e000
+pkgver=1.1.r18.ga576a1e
pkgrel=1
pkgdesc="A distributed, real-time instant messaging system"
arch=('i686' 'x86_64')
url="http://gale.org"
license=('GPL2')
-depends=('bash' 'gc' 'openssl' 'adns')
+depends=('bash' 'gc' 'openssl' 'adns' 'glib2' 'tcl')
makedepends=('git')
install="${_pkgname}.install"
source=("${_pkgname}::git+https://github.com/grawity/${_pkgname}.git")
sha1sums=('SKIP')
pkgver() {
- cd "$srcdir/$_pkgname"
+ cd ${_pkgname}
git describe --tags | sed 's/^v//; s/-/.r/; s/-/./g'
}
prepare() {
- cd "$srcdir/$_pkgname"
+ cd ${_pkgname}
if [[ ! -f configure ]]; then
./bootstrap
@@ -30,14 +30,15 @@ prepare() {
}
build() {
- cd "$srcdir/$_pkgname"
-
+ cd ${_pkgname}
./configure --prefix=/usr --sysconfdir=/etc
- make -j1 # parallel builds seem to be broken
+ make -C liboop liboop-tcl.la liboop-glib2.la liboop-rl.la liboop-adns.la #without this line build fails
+ make -C libgale libgale.la # without this line build fails
+ make # parallel builds seem to be broken
}
package() {
- cd "$srcdir/$_pkgname"
+ cd ${_pkgname}
make DESTDIR="$pkgdir" install
# install fails if sbindir = bindir