summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMagnus Boman2022-04-08 21:23:14 +0200
committerMagnus Boman2022-04-08 21:23:14 +0200
commited33c78bb3324909d270573a574efa7ef473c97c (patch)
treef9ca4ab8e6e27c045c368c2554b68affc17e24c9 /PKGBUILD
parent664a0b432312b16841afb0b0bab589a1112a3f56 (diff)
downloadaur-ed33c78bb3324909d270573a574efa7ef473c97c.tar.gz
upgpkg: gallery-dl 1.21.1-1
upstream release Switch to PEP517
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 97dd88cf8506..84b1984754e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
# Contributor: LLL2yu <lll2yu@protonmail.com>
pkgname=gallery-dl
-pkgver=1.21.0
+pkgver=1.21.1
pkgrel=1
pkgdesc='Command-line program to download image-galleries and collections from several image hosting sites'
arch=(any)
url=https://github.com/mikf/gallery-dl
license=(GPL2)
depends=(python python-requests)
-makedepends=(python-setuptools git)
+makedepends=(python-build python-installer python-setuptools python-wheel git)
optdepends=('ffmpeg: Convert Pixiv Ugoira to WebM'
'youtube-dl: Download videos'
'python-pysocks: SOCKS support')
@@ -20,7 +20,7 @@ sha512sums=('SKIP')
build() {
cd ${pkgname}
make
- python setup.py build
+ python -m build --wheel --no-isolation
}
check() {
@@ -29,5 +29,5 @@ check() {
package() {
cd ${pkgname}
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}