summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSam2021-07-26 19:57:27 -0700
committerSam2021-07-26 19:58:51 -0700
commit966fd28e835bfbfd08a852bda241e6a6866c4fd5 (patch)
tree2d69d01fb49df98511729e3bc2c3bffad90c5c13 /PKGBUILD
parentb36cbf607187eac2faa80666cdb1124a3aa988e5 (diff)
downloadaur-966fd28e835bfbfd08a852bda241e6a6866c4fd5.tar.gz
upgpkg: gallery-dl-bin 1.18.2-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 15 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f3e366d9e6d3..1a80eec2c5ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,30 +4,34 @@
# https://github.com/mikf/gallery-dl/issues/1117
# This binary release pushes this burden of dependency version resolution to the creator
+# shellcheck disable=2034,2148,2154
+
pkgname=gallery-dl-bin
-pkgver=1.18.1
+_pkgname=gallery-dl
+pkgver=1.18.2
pkgrel=1
url='https://github.com/mikf/gallery-dl'
pkgdesc='Command-line program to download image-galleries and collections from several image hosting sites (bin)'
arch=('x86_64')
depends=('zlib')
-provides=('gallery-dl')
-conflicts=('gallery-dl' 'gallery-dl-git')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}" "${_pkgname}-git")
license=(GPL2)
source=("${url}"/releases/download/v"${pkgver}"/gallery-dl.bin{,.sig}
- https://api.github.com/repos/mikf/gallery-dl/releases/latest)
+ "https://api.github.com/repos/mikf/${_pkgname}/releases/latest")
validpgpkeys=('3E09F5908333DD83DBDCE7375680CA389D365A88')
-sha256sums=('SKIP' 'SKIP' 'SKIP')
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
- cd "${srcdir}"
- chmod +x gallery-dl.bin
- grep -oP 'https://.*gallery-dl.bin' latest |
+ cd "${srcdir}" || exit
+ grep -oP "https://.*${_pkgname}.bin" latest |
head -n1 |
- sed -re 's|.*/v(.*)/gallery-dl.bin|\1|g'
+ sed -re "s|.*/v(.*)/${_pkgname}.bin|\1|g"
}
package() {
- cd "${srcdir}"
- install -Dm0775 gallery-dl.bin "${pkgdir}"/usr/bin/gallery-dl
+ cd "${srcdir}" || exit
+ install -Dm0755 "${_pkgname}.bin" "${pkgdir}/usr/bin/${_pkgname}"
}