summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrederic Bezies2015-06-15 22:09:58 +0200
committerFrederic Bezies2015-06-15 22:09:58 +0200
commit8ede72fc7085a205dd640af9da93cdedd707d82f (patch)
tree04107cf04599662f844cd81245fb22a4c0968009 /PKGBUILD
downloadaur-8ede72fc7085a205dd640af9da93cdedd707d82f.tar.gz
initial commit on aur4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb1a09abf39c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer : Frederic Bezies <fredbezies at gmail dot com>
+# Contributor: kusakata <shohei atmark kusakata period com>
+
+pkgname=galois
+pkgver=0.3
+pkgrel=2
+pkgdesc='A computer game of the "falling blocks" type, but with unique features'
+arch=('i686' 'x86_64')
+url="http://www.nongnu.org/galois/"
+license=('GPL3')
+depends=('gtkmm' 'libxml++')
+source=("http://download.savannah.gnu.org/releases/galois/source/galois-${pkgver}.tar.gz")
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="$pkgdir" install
+ cd "${pkgdir}/usr"
+ mv games bin
+}
+
+md5sums=('379b33ac28b1c5140c59aefae0b69964')