summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatti Niemenmaa2018-03-16 17:05:13 +0200
committerMatti Niemenmaa2018-03-16 17:05:13 +0200
commit2e8e7720564497154b7bfe0b8a1d4ebd86c09285 (patch)
tree7b30d3c0ea1c0ffb4429535bf13fba628840ba49 /PKGBUILD
parent83ee823e1ebd0c6b365be1369673f9a4679596c7 (diff)
downloadaur-2e8e7720564497154b7bfe0b8a1d4ebd86c09285.tar.gz
Link with -Bsymbolic to reduce symbol leak issues
Plenty of internal symbols are exported, with rather generic names that can (and do) conflict with other libraries. So link with -Bsymbolic, which prevents overriding them with LD_PRELOAD but also prevents such conflicts from causing problems with functions here accidentally calling some other library's functions.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 062c4ae84c3e..daee58051f07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Matti Niemenmaa <matti.niemenmaa+aur ät iki dȯt fi>
pkgname=game_music_emu-kode54-git
-pkgver=r191.b757c4a
-pkgrel=2
+pkgver=r192.d3df0db
+pkgrel=1
pkgdesc="Multi-purpose console music emulator and player library (a.k.a. libgme) (kode54's fork)"
arch=(i686 x86_64)
url='https://gitlab.kode54.net/kode54/Game_Music_Emu'
@@ -42,7 +42,7 @@ prepare() {
headers.path = /usr/include/gme
headers.files += ../../gme/gme.h
INSTALLS += headers
-QMAKE_LFLAGS += -Wl,--allow-multiple-definition -lz
+QMAKE_LFLAGS += -Wl,--allow-multiple-definition -Wl,-Bsymbolic -lz
EOF
}