summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2019-01-30 00:27:48 +0100
committerFabioLolix2019-01-30 00:27:48 +0100
commitf9b5e28aa932c0e02b8cfdc3ce6d354ca91cb5fd (patch)
treea1b3babb19c83268e957a2be7eb58b1dc27c9573 /PKGBUILD
parente4df72d88ffac3ae7f4185e7551fb7491a14eb46 (diff)
downloadaur-f9b5e28aa932c0e02b8cfdc3ce6d354ca91cb5fd.tar.gz
Update & revision
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 21 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cc257b8e78d2..1123696af1b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,31 @@
-# Maintainer: Robert Stoffers <rstoffers@gmail.com>
+# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org>
+# Maintainer: tkashkin
+# Maintainer: neuromancer
+# Contributor: friday (github)
+# Contributor: Robert Stoffers <rstoffers@gmail.com>
pkgname=gamehub
-pkgver=0.6.2
+_pkgver=0.13.1-1-master
+pkgver=${_pkgver//-/.}
pkgrel=1
-pkgdesc="Games manager/downloader/library written in Vala that supports GOG, Steam and Humble Bundle"
-arch=('any')
+pkgdesc="Games manager, downloader, library that supports GOG, Steam and Humble Bundle. Designed for Pantheon Shell"
+arch=(i686 x86_64 armv6h armv7h aarch64)
url="https://github.com/tkashkin/GameHub"
-license=('unknown')
-depends=('granite' 'gtk3' 'glibc' 'webkit2gtk' 'json-glib' 'libgee' 'libsoup' 'sqlite' 'gdk-pixbuf2' 'cairo')
-makedepends=('meson' 'ninja' 'vala')
-conflicts=('gamehub-git')
-source=("GameHub-$pkgver.tar.gz"::https://github.com/tkashkin/GameHub/archive/$pkgver.tar.gz)
-md5sums=('15f58636acd5946185fbca1c65a6a17c')
+license=(GPL3)
+depends=(libgranite.so gtk3 glib2 libgee libsoup json-glib sqlite webkit2gtk libmanette libxtst)
+makedepends=(meson ninja vala)
+options=(!strip debug)
+source=("GameHub-$pkgver.tar.gz::https://github.com/tkashkin/GameHub/archive/${_pkgver}.tar.gz")
+sha256sums=('387412b6203b1e68bfec27ef7fab46e5dbf7e9cd5cebce6b6698a00e67d9b7e0')
build() {
- cd "GameHub-$pkgver"
- meson build --prefix=/usr -Ddistro=arch
- cd build
- ninja
+ cd "GameHub-$_pkgver"
+ CFLAGS="$CFLAGS -O0" meson . build --prefix=/usr -Ddistro=arch --buildtype=debug
+ ninja -C build
}
package() {
- cd "GameHub-$pkgver"/build
- DESTDIR=$pkgdir ninja install
- sudo ln -s /usr/bin/com.github.tkashkin.gamehub /usr/bin/gamehub
+ cd "GameHub-$_pkgver"
+ DESTDIR="${pkgdir}" ninja -C build install
+ ln -s /usr/bin/com.github.tkashkin.gamehub "$pkgdir/usr/bin/gamehub"
}