summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2020-09-12 20:50:25 -0600
committerMark Wagie2020-09-12 20:50:25 -0600
commit25593ef60c31bed1c08fe81399224d8ecee14b98 (patch)
tree00760b7e68c03bf4b5248e43025de875ac131167 /PKGBUILD
parentd1be8593c289e6d7b6598ded9501aa7ddac4e403 (diff)
downloadaur-25593ef60c31bed1c08fe81399224d8ecee14b98.tar.gz
remove unnecessary deps, add install file, PKGBUILD tweaks
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 16 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5921b242788e..5becd88da2e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,34 @@
# Maintainer: Ysblokje <ysblokje at gmail dot com>
-pkgname=('gamemode')
+# Co-Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=gamemode
pkgver=1.6
pkgrel=1
-pkgdesc="A daemon/lib combo for Linux that allows games to request a set of optimisations be temporarily applied to the host OS"
+pkgdesc="A daemon/lib combo that allows games to request a set of optimisations be temporarily applied to the host OS"
arch=('x86_64')
-url="https://github.com/FeralInteractive/gamemode.git"
+url="https://github.com/FeralInteractive/gamemode"
license=('BSD 3-Clause License (Revised)')
-optdepends=('systemd')
depends=('polkit')
-makedepends=('meson' 'ninja' 'pkg-config')
-source=("https://github.com/FeralInteractive/gamemode/releases/download/$pkgver/$pkgname-$pkgver.tar.xz"
+makedepends=('meson')
+optdepends=('systemd')
+source=("$url/releases/download/$pkgver/$pkgname-$pkgver.tar.xz"
)
sha256sums=('4fec5a0900e8f559b37cf1711ca7dcea7e1cebfe1237ce314001f65c1e346a5d'
)
build() {
- meson gamemode-$pkgver build --prefix /usr --libexecdir lib/gamemode -Dwith-pam-group=gamemode -Dwith-systemd-user-unit-dir=/usr/lib/systemd/user
- #meson ${_pkgname} build --prefix /usr -Dwith-systemd-user-unit-dir=/usr/lib/systemd/user -Dwith-pam-group=gamemode
+ meson "$pkgname-$pkgver" build \
+ --prefix /usr \
+ --libexecdir lib/gamemode \
+ -Dwith-pam-group=gamemode \
+ -Dwith-systemd-user-unit-dir=/usr/lib/systemd/user
ninja -C build
}
package() {
DESTDIR=$pkgdir ninja -C build install
- install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" ${pkgname}-${pkgver}/LICENSE.txt
- install -m644 -Dt "${pkgdir}/usr/share/doc/${pkgname}/example" ${pkgname}-${pkgver}/example/gamemode.ini
+ install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" \
+ ${pkgname}-${pkgver}/LICENSE.txt
+ install -m644 -Dt "${pkgdir}/usr/share/doc/${pkgname}/example" \
+ ${pkgname}-${pkgver}/example/gamemode.ini
}