summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorQuey-Liang Kao2016-04-05 12:01:43 +0800
committerQuey-Liang Kao2016-04-05 12:01:43 +0800
commitaec5576b015fd8c6b873fa819ee510d33945e50c (patch)
tree6de6c0d40ee510f9806476396271bffad478f2cf /PKGBUILD
parent90df31463491485be788a0fb2303f11a746e135f (diff)
downloadaur-gameplay3d.tar.gz
Update and fix some style problems
* sudo sould not be use * useless package() is not good, packed to /opt instead * update to 3.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 30 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1bd510218105..733ab7eb0da5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ross Harrison <rtharrison86@gmail.com>
pkgname=gameplay3d
-pkgver=0.1
+pkgver=3.0.0
pkgrel=1
pkgdesc="Open-source, cross-platform, C++ game framework/engine for creating 2D/3D mobile and desktop games."
arch=('any')
@@ -9,23 +9,46 @@ url="https://github.com/gameplay3d/GamePlay"
license=('Apache 2.0')
depends=('gcc' 'cmake' 'unzip')
-source=("$pkgname"::'git+https://github.com/gameplay3d/GamePlay.git')
-sha512sums=('SKIP')
+source=("$pkgname"::'git+https://github.com/gameplay3d/GamePlay.git'
+ "path.patch")
+sha512sums=('SKIP'
+ 'f8e96b9de2cb57ace265465e3d02c7314e58dc73bca91b417a1517d24106e042bed67edd5e4ddedf6a36aea2ecdb70e85baab50bc0cabbd9434ff5852474ec68')
+
+# Path fix here
+prepare() {
+ local _p
+ for _p in *.patch; do
+ [[ -e $_p ]] || continue
+ msg2 "Applying $_p"
+ patch -p1 -d $pkgname < "$_p"
+ done
+}
build() {
- sudo mv $pkgname /usr/share/
- cd /usr/share/$pkgname
+ cd $srcdir/$pkgname
# install dependencies
./install.sh
# build
+ rm -fr build
mkdir build
cd build
cmake ..
- make
+
+ # adjust this part according to your environment
+ make # -j12
}
+# Since this is a self-containing development kit,
+# I choose to pack this into /opt.
package(){
- echo "OK"
+ mkdir -p $pkgdir/opt
+ cp -r $srcdir/$pkgname $pkgdir/opt/
+
+ # An intuitive use of this package is to execute newproject script,
+ mkdir -p $pkgdir/usr/bin
+ ln -s /opt/$pkgname/newproject.sh $pkgdir/usr/bin/gameplay3d
+
+ echo "execute gameplay3d to new your project!"
}