summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSefa Eyeoglu2020-10-31 00:13:15 +0100
committerSefa Eyeoglu2020-10-31 00:13:15 +0100
commit3788e1b66f099843d59c06ed28a62152c184b28a (patch)
tree8285316dc85d4e0c8466f842cf108c43917f9b56 /PKGBUILD
parent0cbcc8bed316b16a8c8af40d75d61f32eac4ba06 (diff)
downloadaur-3788e1b66f099843d59c06ed28a62152c184b28a.tar.gz
upgpkg: gamescope-git 3.7.r11.gcd31090-1
Update to support new submodule handling
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 224088089c15..c5b46791ea78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=gamescope
pkgname=${_pkgname}-git
-pkgver=3.6.9.r21.g5644232
+pkgver=3.7.r11.gcd31090
pkgrel=1
pkgdesc="Micro-compositor formerly known as steamcompmgr"
arch=(x86_64)
@@ -12,10 +12,8 @@ depends=("wlroots-git" "sdl2" "libxcomposite" "vulkan-icd-loader" "libxtst" "lib
makedepends=("git" "meson" "ninja" "patch" "vulkan-headers" "glslang")
provides=($_pkgname "steamcompmgr")
conflicts=($_pkgname "steamcompmgr")
-source=("git+https://github.com/Plagman/gamescope.git"
- "use-system-libs.patch")
-sha512sums=('SKIP'
- 'a36d6bef5ea19a0754ab82df5bc2c5f64c23321fde7be33073953dad76eb8c0af64ae1b5723f4e778a403c6bf75d4df27a524899de3b412d2bacd1cd4052e86a')
+source=("git+https://github.com/Plagman/gamescope.git")
+sha512sums=('SKIP')
pkgver() {
@@ -25,14 +23,14 @@ pkgver() {
}
prepare() {
- cd "$srcdir/$_pkgname"
- patch -p1 < "../use-system-libs.patch"
+ rm -rf "$srcdir/$_pkgname/subprojects/libliftoff"
+ rm -rf "$srcdir/$_pkgname/subprojects/wlroots"
}
build() {
- meson --prefix /usr --buildtype=release "$srcdir/$_pkgname" build
+ meson setup --prefix /usr --buildtype=release --wrap-mode=nodownload "$srcdir/$_pkgname" build
ninja -C build
}