summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordetiam2024-09-07 19:08:32 +0800
committerdetiam2024-09-07 19:08:32 +0800
commit2e2e73ee51f13e611240ebceb72992261bf4c58b (patch)
treed61fb62ae9d43de2de7acf650dee2016f7fffb0d /PKGBUILD
parent60655f46d3b2b9ead153e0a3ea07c13124d60ce6 (diff)
downloadaur-2e2e73ee51f13e611240ebceb72992261bf4c58b.tar.gz
update to updpkgsrcs#2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 32ac19d80071..9e98aee1d998 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -67,8 +67,13 @@ prepare() {
cd $_pkgname
msg2 'Retrieving git build dependencies...'
- updpkgsrcs updateBuildScriptForSubModule || exit $?
- eval "$(updpkgsrcs echoGitCMDForSubModule)" || exit $?
+ local outmsg='first'; until [[ -z $outmsg ]]; do
+ if outmsg=$(eval "$(updpkgsrcs echoGitCMDForSubModule force)" 2>&1); then
+ echo "$outmsg"
+ else
+ echo "$outmsg"; updpkgsrcs updateBuildScriptForSubModule || exit $?
+ fi
+ done; unset outmsg
msg2 'Retrieving meson build dependencies...'
sed -i "s#^url =.*#url = file://$srcdir/subprojects|stb#" subprojects/stb.wrap