summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordetiam2024-01-27 01:31:18 +0800
committerdetiam2024-01-27 01:31:18 +0800
commita5faa4e8d3b9255c02c6135c57209f0464b17199 (patch)
tree1925340a20202b3368cb76b872017b0b414b299c /PKGBUILD
parentb8ef1aa5a0b00871c2ecf3e6079bae2a4bf862cc (diff)
downloadaur-a5faa4e8d3b9255c02c6135c57209f0464b17199.tar.gz
fix build error for new commit
openvr hasn't update in arch repo, so build it from source.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD81
1 files changed, 30 insertions, 51 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 525e9aca7fa5..b9c4f21d3fd5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,74 +6,50 @@
pkgname=gamescope-nvidia-git
_pkgname=gamescope
-pkgver=3.13.18.r8.gb7c828b
+pkgver=3.14.0.r1.gdc81258
pkgrel=1
pkgdesc='SteamOS session compositing window manager (NVIDIA patch)'
arch=(x86_64)
-url=https://github.com/sharkautarch/gamescope
+url=https://github.com/sharkautarch/gamescope/tree/nvidia-fix
license=(BSD)
install="$_pkgname.install"
depends=(
- gcc-libs
- glibc
- libcap.so
- libdisplay-info.so
- libdrm
- libliftoff.so
- libpipewire-0.3.so
- libvulkan.so
- libwlroots.so
- libx11
- libxcb
+ libpipewire
+ libcap
+ libliftoff
libxcomposite
libxdamage
- libxext
- libxfixes
- libxkbcommon.so
+ libxkbcommon
libxmu
- libxrender
libxres
- libxtst
libxxf86vm
- openvr
sdl2
vulkan-icd-loader
- wayland
- xorg-server-xwayland
-)
+ xorg-xwayland
+ wlroots)
makedepends=(
git
glslang
meson
ninja
- vulkan-headers
- wayland-protocols
vkroots
- glm
-)
+ vulkan-headers
+ wayland-protocols)
+optdepends=(
+ 'openvr: require openvr 2.0 for vr')
provides=(
- "$_pkgname"
-)
+ "$_pkgname")
conflicts=(
- "$_pkgname"
-)
+ "$_pkgname")
source=(
- 0001-Revert-rendervulkan-Get-a-general-graphics-compute-q.patch
- 0002-fix-error-due-to-removed-general-command-pool.patch
- 0003-oops.patch
- 0004-fix-removed-general-queue.patch
- git+https://github.com/ValveSoftware/gamescope.git
- git+https://github.com/Joshua-Ashton/reshade.git
- git+https://github.com/KhronosGroup/SPIRV-Headers.git
-)
-b2sums=('f0a7562a7825df16878f733669056dc5ecda36e62afc945e745b6746ee7ecf6983d4659b0061f73852165537479fac68ecd59913b2ff6fdc5ac18ff23d891d97'
- '6c5e3cc88cd4882ea6a1a1afa7a47d93dcc665128d7fa125d619440303530f4f774046ae157134521b15df022fc389241b7a58cf386aec53de98a67983a3589a'
- '62a07d81a63d390be1c4bc838b4dea920c41efb37ca6aff919696f8ca104b688eeeea896fb2a4706b20f487578864bbaee4f09fe4b764b5a17cc6384bed1cd38'
- 'bde7af1325b29ee4456272cf04c999d9248d320334d1794ebf3181962b93f8d30c31e308d73b4d67f592729bda59763f790890b7d82e7d8e951ed2f8415d9b36'
- 'SKIP'
+ "git+https://github.com/ValveSoftware/gamescope.git"
+ "git+https://github.com/Joshua-Ashton/reshade.git"
+ "git+https://github.com/KhronosGroup/SPIRV-Headers.git"
+ "0001-reverts-bd722f7.patch")
+b2sums=('SKIP'
'SKIP'
'SKIP'
-)
+ 'a8ee82c988cfcbaca755421020443034d07c3417546d5a41c39c8709cb1abbef5c0c0ad273ddd3e3d44a650f0bdaf7bf81fad02436937ef7389051efc96d19d5')
prepare() {
# apply nvidia-fix patchs from
@@ -85,13 +61,16 @@ prepare() {
fi
done
+ # download build deps
cd gamescope
- meson subprojects download stb
- git submodule init src/reshade
- git config submodule.src/reshade.url ../reshade
- git submodule init thirdparty/SPIRV-Headers
- git config submodule.thirdparty/SPIRV-Headers.url ../SPIRV-Headers
- git -c protocol.file.allow=always submodule update
+ git -c submodule.src/reshade.url="$srcdir/reshade" \
+ -c submodule.thirdparty/SPIRV-Headers.url="$srcdir/SPIRV-Headers" \
+ -c submodule.subprojects/wlroots.update=none \
+ -c submodule.subprojects/libdisplay-info.update=none \
+ -c submodule.subprojects/libliftoff.update=none \
+ -c submodule.subprojects/vkroots.update=none \
+ -c protocol.file.allow=always submodule update --init --progress
+ meson subprojects download stb glm
}
pkgver() {
@@ -100,7 +79,7 @@ pkgver() {
build() {
arch-meson gamescope build \
- -Dforce_fallback_for=stb \
+ -Dforce_fallback_for=stb,glm \
-Dbenchmark=disabled \
-Dpipewire=enabled
meson compile -C build