summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhonjow2024-03-04 18:04:46 +0000
committerhonjow2024-03-04 18:04:46 +0000
commit77b3c4cb5d498d569d0a7a392f90f07d8b31982a (patch)
tree9513fa68f084383dbe0b0c8f527863f28ca329a2 /PKGBUILD
parentcbd18390301195590986ce722b7d03e4fcccd3b4 (diff)
downloadaur-77b3c4cb5d498d569d0a7a392f90f07d8b31982a.tar.gz
Update AUR package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2908d7a838ab..853c8a24cf6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
_pkgname=gamescope
pkgname=${_pkgname}-sk-git
-pkgver=3.14.1.r15.g6ed7472
+pkgver=3.14.1.r26.g3e9ab3b
pkgrel=1
pkgdesc='SteamOS session compositing window manager'
arch=(x86_64)
@@ -52,6 +52,7 @@ makedepends=(
# _tag=62d425164d383fcde498b17b0af5d00bfa92aed4
_branch="sk-gamescope"
source=("git+https://github.com/3003n/gamescope.git#branch=${_branch}"
+ "git+https://github.com/nothings/stb.git#commit=af1a5bc352164740c1cc1354942b1c6b72eacb8a"
"git+https://github.com/Joshua-Ashton/GamescopeShaders.git#tag=v0.1"
"git+https://github.com/Joshua-Ashton/reshade.git"
"git+https://github.com/KhronosGroup/SPIRV-Headers.git"
@@ -60,6 +61,7 @@ source=("git+https://github.com/3003n/gamescope.git#branch=${_branch}"
b2sums=('SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
provides=("$_pkgname")
@@ -81,6 +83,11 @@ prepare() {
git submodule init thirdparty/SPIRV-Headers
git config submodule.thirdparty/SPIRV-Headers.url ../SPIRV-Headers
git -c protocol.file.allow=always submodule update
+
+ # make stb.wrap use our local clone
+ rm -rf subprojects/stb
+ git clone "$srcdir/stb" subprojects/stb
+ cp -av subprojects/packagefiles/stb/* subprojects/stb/ # patch from the .wrap we elided
}
pkgver() {
@@ -108,5 +115,3 @@ package() {
cd "$srcdir/$_pkgname"
install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/$pkgname/"
}
-
-# vim: ts=2 sw=2 et: \ No newline at end of file