summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhonjow2024-03-04 16:29:41 +0000
committerhonjow2024-03-04 16:29:41 +0000
commit8894b1a0fe30ee6d776947720c12569cc889f8a0 (patch)
treeb70713351dc956fb9898d2675e92651b89632bcc /PKGBUILD
parent360d691672c7466c2f16d8247254fc370a08bb14 (diff)
downloadaur-8894b1a0fe30ee6d776947720c12569cc889f8a0.tar.gz
Update AUR package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 29 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2cda7196e9e3..3d2441845a79 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,6 @@
-
_pkgname=gamescope
pkgname=${_pkgname}-sk-git
-pkgver=3.14.1.r14.gc3c54be
+pkgver=3.14.1.r15.g6ed7472
pkgrel=1
pkgdesc='SteamOS session compositing window manager'
arch=(x86_64)
@@ -49,10 +48,20 @@ makedepends=(
ninja
vulkan-headers
wayland-protocols
+ openvr-git
)
-_branch=sk-gamescope
-source=("git+https://github.com/3003n/gamescope.git#branch=${_branch}")
-b2sums=('SKIP')
+# _tag=62d425164d383fcde498b17b0af5d00bfa92aed4
+_branch="sk-gamescope"
+source=("git+https://github.com/3003n/gamescope.git#branch=${_branch}"
+ "git+https://github.com/Joshua-Ashton/GamescopeShaders.git#tag=v0.1"
+ "git+https://github.com/Joshua-Ashton/reshade.git"
+ "git+https://github.com/KhronosGroup/SPIRV-Headers.git"
+ )
+
+b2sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
provides=("$_pkgname")
conflicts=("$_pkgname")
@@ -68,11 +77,11 @@ prepare() {
git apply "../$src"
done
meson subprojects download
- git submodule init
+ git submodule init src/reshade
+ git config submodule.src/reshade.url "$srcdir/reshade"
+ git submodule init thirdparty/SPIRV-Headers
+ git config submodule.thirdparty/SPIRV-Headers.url ../SPIRV-Headers
git -c protocol.file.allow=always submodule update
-
- # Use Arch provided libdisplay-info, do use other subprojects as is
- rm -rf subprojects/libdisplay-info
}
pkgver() {
@@ -81,13 +90,20 @@ pkgver() {
}
build() {
- arch-meson "${_pkgname}" build \
- -Dforce_fallback_for=stb \
- -Dpipewire=enabled
- meson compile -C build
+ export LDFLAGS="$LDFLAGS -lrt"
+ arch-meson gamescope build \
+ -Dforce_fallback_for=stb,libliftoff,wlroots \
+ -Dpipewire=enabled \
+ -Dwlroots:backends=drm,libinput,x11 \
+ -Dwlroots:renderers=gles2,vulkan
+ ninja -C build
}
package() {
+ install -d "$pkgdir"/usr/share/gamescope/reshade
+ cp -r "$srcdir"/GamescopeShaders/* "$pkgdir"/usr/share/gamescope/reshade/
+
+ chmod -R 655 "$pkgdir"/usr/share/gamescope
meson install -C build --skip-subprojects --destdir="${pkgdir}"
cd "$srcdir/$_pkgname"