summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnton Kudelin2021-07-29 23:59:53 +0300
committerAnton Kudelin2021-07-29 23:59:53 +0300
commitb7764d0fd16749a7216de183cd915ef23c37922e (patch)
treec03f35dc15ad6d532b985f03c9ee96244398f32b /PKGBUILD
parentad004ed1c1779afdd8aad297175734a3cceddd6b (diff)
downloadaur-b7764d0fd16749a7216de183cd915ef23c37922e.tar.gz
updpkg: 2021R1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD54
1 files changed, 25 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7c37764d9a66..de2ef068af97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,41 +3,33 @@
# Maintainer: Eric Berquist <eric.berquist at gmail dot com>
pkgname=gamess
-pkgver=2020R2
-pkgrel=3
+pkgver=2021R1
+pkgrel=1
pkgdesc="The General Atomic and Molecular Electronic Structure System"
arch=('x86_64')
url="https://www.msg.chem.iastate.edu/gamess/gamess.html"
license=('custom')
-depends=('tcsh' 'blas' 'python')
+depends=('tcsh' 'blas' 'python' 'libxc' 'perl')
makedepends=('python-jinja' 'gcc-fortran')
checkdepends=('inetutils')
-install=${pkgname}.install
+install=$pkgname.install
# You have to get the package from the official website
# and put into the current directory.
source=("local://gamess-current.tar.gz"
- "opt.patch"
- "tests.patch")
-sha256sums=('5eb9242751159b6de244055e1bbb5987e052f913d47ce5eb8a4c6d262361cdc3'
- '4ed0f7c17df595c02a7cc42b777cf64005eb84fedb5b6306936241b20dd523e3'
- '38a14c4d428b54838b55ed19cc9aa6741992c2e7b66a0180994d264de71c6bf2')
+ "comp.patch")
+sha256sums=('61283d56ad02513bc40a729ed26566a11e8c298e560d7c4a37254ff725b7ab30'
+ 'a003a611b658c9073954fb0041f077ec1a910310db73201c97829eb2654b8e43')
prepare() {
cd "$srcdir/$pkgname"
- patch -p1 < "$srcdir/tests.patch"
-
# You may comment out two lines below to let GAMESS choose compiler options.
- patch -p1 < "$srcdir/opt.patch"
+ patch -p1 < "$srcdir/comp.patch"
echo "Compiler flags '-O3 -march=native -mno-fma' are enabled by default."
-
- # Optimizations can safely be more aggressive.
- sed -i 's/ -fno-aggressive-loop-optimizations//g' comp
-
- # Fixes for GCC Fortran > 9
- sed -i 's/-ffree-line-length-none/-ffree-line-length-none -fallow-argument-mismatch/g' comp
- sed -i 's/-Ofast -ffast-math/-Ofast -ffast-math -fallow-argument-mismatch/g' comp
+
+ # Shared LIBXC
+ sed -i 's@$GMS_PATH/libxc_lib/lib/libxcf03.a $GMS_PATH/libxc_lib/lib/libxc.a@-lxcf03 -lxc@g' lked
# Blas-agnostic
sed -i 's/-lopenblas/-lblas/g' lked
@@ -49,25 +41,29 @@ build() {
--fortran_version=10.2 \
--openblas \
--mathlib_path=/usr/lib \
- --openmp
+ --openmp \
+ --libxc
make modules -j1
make
}
check() {
- echo "Please, wait for the computation of 47 test examples to finish."
+ echo "Please, wait for the computation of 48 test examples to finish."
echo "It is going to take about 5 min depending on your CPU frequency."
cd "$srcdir/$pkgname"
-
+
# Prepare the launch script "rungms" to testing.
sed -i '/set GMSPATH=/c\set GMSPATH=$PWD' rungms
sed -i '/set SCR=/c\set SCR=\/tmp' rungms
mkdir scr
sed -i '/set USERSCR=/c\set USERSCR=$PWD\/scr' rungms
-
+
# Fixing the number of tests
sed -i 's/47/48/' runall
-
+
+ # Fixing 43rd test
+ sed -i '/dirscf=.true./d' tests/standard/exam43.inp
+
# Start testing with the use of 1 CPU core.
./runall 00
tests/standard/checktst
@@ -76,19 +72,19 @@ check() {
package() {
cd "$srcdir/$pkgname"
-
- # Fix rungms
+
+ # Fixing rungms
sed -i '/set GMSPATH=/c\set GMSPATH=/opt/gamess' rungms
sed -i '/set SCR=/c\set SCR=\/tmp' rungms
sed -i '/set USERSCR=/c\set USERSCR=$HOME\/.gamess' rungms
-
+
install -dm755 "$pkgdir/opt/gamess"
install -dm755 "$pkgdir/usr/bin"
install -m755 *.x "$pkgdir/opt/gamess"
install -m755 run* "$pkgdir/opt/gamess"
install -m755 gms-files.csh "$pkgdir/opt/gamess"
-
+
cp -r auxdata tools vb2000 "$pkgdir/opt/gamess"
-
+
ln -sf /opt/gamess/rungms "$pkgdir/usr/bin"
}